[LinuxBIOS] get some output on serial console of commel lv671 board, but not readable one

Dieter Bloms linuxbios at bloms.de
Sat Jun 16 07:39:07 CEST 2007


On Fri, Jun 15, Corey Osgood wrote:

> Interesting...the ICH also says the same thing, but I didn't have to do
> any such thing to get serial output. The intel xe7501devkit, which is
> ICH3, doesn't do it either, nor does the jarrell, which is ICH5R. Given
> that, I'd say the datasheets lie, and in any case it couldn't hurt to
> try it ;)

have tried your changes, but then I get nothing on serial.

> Also, the tyan s2875 has the same superio as yours, and doesn't do any
> special setup for it at all, just w83627hf_enable_serial. You might want
> to take a quick peak at the auto.c there. From a running system, you
> should be able to determine if it's on 0x2e or 0x4e, just start doing
> inb from the command line, using 0x2e/4e as a starting point and
> counting up, when you start finding non-0xff values you've found
> _something_, although there's no guarantee its the serial port. Some
> distros (*cough* ubuntu *cough*) don't allow you to do anything under
> 0x100 though, but iirc arch and debian do it fine.

I run a debian.
What do you mean with inb from command line ?



I do not get viruses because I do not use MS software.
If you use Outlook then please do not put my email address in your
address-book so that WHEN you get a virus it won't use my address in the
From field.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070616/49c275d7/attachment.sig>

More information about the coreboot mailing list