[LinuxBIOS] Can't boot from IDE on vt8237r

Peter Stuge peter at stuge.se
Thu Jul 26 18:23:55 CEST 2007

On Thu, Jul 26, 2007 at 05:25:50AM -0400, Corey Osgood wrote:
> > You could also try using my FILO IDE patch with the debugging
> > suggested in my message, it may provide some more debugging hints:
> Still no dice, doesn't seem to give any extra info (with your patch
> and debugging). New log file attached, FILO can now find an SATA
> drive (formatted in reiserfs, which I didn't include support for in
> FILO).

Add the reiserfs support to FILO and it should load the kernel.

> IDE is still showing up as a floating bus.



> file_open: dev=hda1, path=/vmlinuz
> find_ide_controller: found PCI IDE controller 1106:3149 prog_if=0x8f
> find_ide_controller: primary channel: native PCI mode
> find_ide_controller: cmd_base=0x2020 ctrl_base=0x2040
> ide_software_reset: Waiting for ide0 to become ready for reset... ok
> init_drive: Testing for hda
> init_drive: Probing for hda
> init_drive: LBA mode, sectors=160836480
> init_drive: LBA48 mode, sectors=160836480
> init_drive: Init device params... ok
> hda: LBA48 82GB: HDS728080PLA380                         

Bingo, here's an LBA48 82GB disk on hda.

> init_drive: Testing for hdb
> init_drive: Testing for hdb
> ide_readmany: sector 0 to 001105c0
> devopen: Partition 1 start 63 length 156456972
> ide_readmany: sector 63 to 001183c0
> ide_readmany: sector 65 to 001107c0
> ide_readmany: sector 66 to 001109c0
> Unknown filesystem type

It's reading the partition table and tries to read a magic
superblock, but FILO doesn't recognize what it is and gives up.


> file_open: dev=hda, path=<NULL>
> devopen: already open
> malloc_diag: alloc: 296 bytes (4 blocks), free: 65232 bytes (1 blocks)
> ide_readmany: sector 1 to 001107c0
> load_linux_header: This looks like a bootdisk image but not like Linux...
> Unsupported image format

Then FILO tries to boot a kernel written directly to the start of the
block device.

.. and then hdb..hdj are tried manually.

Add reiserfs to FILO and try again. :)

Note that my patch will not give as much improvement with reiser as
with ext2. I've only patched ext2 to read multiple blocks,it should
be done in the other fs drivers too.

(But using 32-bit IO should shorten the time by half at least.)


More information about the coreboot mailing list