[LinuxBIOS] Intel 440bx

Uwe Hermann uwe at hermann-uwe.de
Tue Feb 27 13:57:23 CET 2007

On Tue, Feb 27, 2007 at 12:48:01AM -0500, Corey Osgood wrote:
> Use an older compiler, newer gcc versions don't seem to like it. I think
> I used gcc-3.3 on ubuntu. OTOH, compiling v1 is of very little value: we
> know it works, and we have the code, that's all that really matters.

I'll see if I can post a patch to make v1 build.

Back when I last tried this, it looked to me as if RAM init worked (or
at least I thought it worked), but I'm not so sure anymore. I didn't
actually boot a kernel, I only got some debug messages over serial
which I interpreted as 'RAM works', but that might have been wrong...

> BTW, I'm having some trouble with uwe's raminit.c, it seems like
> everything's working right, but the final northbridge dump shows all
> DRB's still set to 0x01. PCI (and hence vga) is also not working, but
> that's much less important.

Don't even try VGA, that's unimportant at this stage and it'll surely
not work anyway.

The goal right now is to get RAM initialized so it can be used at all.
We want to be able to copy stuff (say 0x99) to RAM, then read it back
and it should still be 0x99 (for example).

That's not working at the moment.

http://www.hermann-uwe.de  | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070227/b55c133a/attachment.sig>

More information about the coreboot mailing list