[LinuxBIOS] ICH4 BIOS chip not recognised.

Corey Osgood corey.osgood at gmail.com
Sat Aug 11 05:15:10 CEST 2007

Peter Stuge wrote:
> On Sat, Aug 11, 2007 at 12:26:26AM +0200, Raúl Sánchez Siles wrote:
>>> I use uniflash from:
>> I tried it, but not much successfully. It kinda work (as an app)
>> but it didn't get the needed info. I got this:
>> (FFFF,FFFF) Flash ROM Chip: unknown
>> Organisation: N/A (is write protect disabled?)
>> PCI chipset: Intel 852GM(E)/855GM(E)
>> Last write status: not available
> It does ID your chipset but it seems the flash chip is write
> protected with some unknown GPIO, which makes it impossible to
> identify or write the flash chip from software.

I think this is a bigger problem, something to do with the ICH flash
enable in flashrom. Remember Gürkan Sengün's post:
Not a single ICHx board worked. I know that it's possible that _all_ of
them have GPIO protection, but I have trouble believing it. I've been
planning to look at it, but I simply don't have time, the cn700's eating
what little I have. I think something may have gotten changed at some
point that broke it, but I don't have anything to back up that theory.

Can anyone report flashrom actually working on any ICH board? If so,
what version and board?


More information about the coreboot mailing list