[LinuxBIOS] ICH4 BIOS chip not recognised.

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat Aug 4 03:36:20 CEST 2007

On 04.08.2007 01:51, Raúl Sánchez Siles wrote:
> Hello all:
> I was interested in upgrading my computer BIOS. This is a laptop Dell
> Inspiron 510m. The mother board is an ICH4, more details on request.

Probably a board specific enable routine is needed.

> So I came across flashroom and I tried to use it, and since the motherboard
> was recognised, there wasn't that luck with the BIOS chip. After all this I
> effectively did the upgrade but using the manufacturer recommended biosdisk 
> method (it worked).
> flashrom -V
> Calibrating delay loop... 376M loops per second. ok
> No LinuxBIOS table found.
> Found chipset "ICH4-M": Enabling flash write... OK.
> Probing for Am29F040B, 512 KB
> probe_29f040b: id1 0xea, id2 0xf0
> Probing for Am29F016D, 2048 KB
> probe_29f040b: id1 0xff, id2 0xff

Summary: id1=0xea, id2=0xf0 for every flash size up to and including
1024 kb. Since this happens regardless of the identification routine
used, I assume it is not an ID at all, but some value stored every 128
kb on the flash chip.
This can be verified by using the Dell flash utility to backup the
existing bios and look at the first 2 bytes of the resulting image.

However, using the Dell flash utility to find out the name of the flash
chip would also be helpful.


More information about the coreboot mailing list