[LinuxBIOS] [PATCH] Some more 440BX progress

roger roger at eskimo.com
Mon Apr 30 07:26:32 CEST 2007

On Sun, 2007-04-29 at 14:50 +0200, Uwe Hermann wrote:

> Also, a full boot log is attached. The PCI init _seems_ to work, at
> least partially.
> The current end of the story is that elfboot cannot find the payload,
> not sure why. Wrong PCI init? Wrong RAM init? Wrong payload location?

Spent the whole day playing with options.

While getting more familiar with linux bios, I enabled PCI AGP & APIC
and the code seems to have executed just fine & dandy here.  I also
tried enabling SMP, but seems it also needs MP code.  But getting side
tracked. :-/

I also saw a minor problem with the ordering of addition/subtraction in
src/mainboard/tyan/s1846/Config.lb, the tyan/s2895 had specified a
different order... wasn't it, i think.

Also tried using lzma on file.elf.  

Would love to see more debug output from elfboot. :-/

The patch looks good to me as is.

Key fingerprint = 8977 A252 2623 F567 70CD 1261 640F C963 1005 1D61

Sun Apr 29 22:26:08 PDT 2007

More information about the coreboot mailing list