[LinuxBIOS] Iwill DK8-HTX now runs under LinuxBIOS r2587 (Thanks)

Alexei I. Adamovich lexa at adam.botik.ru
Wed Apr 25 11:07:46 CEST 2007

Hi, Ning!

Sory for delay with replying--I haven't check my email box
tommorow because of being too busy.

Hope, you alredy got the system running, but anyway I'll comment the
problems I had giving the LXBIOS running on my Iwill DK8_HTX box.

1. I needed to choose the payload

I've chosen the etherboot, because only it can load the Linux kernel
from SATA disks we have installed in the system.

2. I needed to get etherboot compiled

I tried etherboot 5.4 (two variants) and had found that it has
problems compiling for LinuxBIOS. So I got 5.2.6, as it was recomended
in the tutorials.

This one is not ready fo compiling on 64-bit Fedora core 4, so I got
32-bit linux box (Debian) to do the job.

The right drivers for me were tg3--filo (not e1000--filo, it doesn't

The AUTOBOOT line in the filo (old version embedded in the Etherboot
should in my case be hde1:..., but not sda1, as I am 

3. I needed to get LinuxBIOS compiled.

This was done on 64-bit Fedora core running on the target platform

The changes I've done in the configuration are in one of my earliest
postst to the LinuxBIOS list. There is one change there that is not
mentioned in the tutorial--it gives the flashrom utility the ability to
program ROM under LinuxBIOS-started Linux (got it from the December
list messeges).

The latest release that is able being compiled AFAIK is 2587.

Some stage in the compilation process needed the intel IASL ACPI
compiler. Did you get it? I've found that I am not able to compile
iasl from the source with no handmade changes--since it wants
an old version of Flex.

So I got proper version of debian 32-bit iasl archive ( 20060912-3.2
was good for me), and extracted the binary out of there, then
copied it to the PATH on 64-bit box (runs with no problem).


NOT APPEND, that takes me 2 days of struggling.

The resulting image is 512KB.

5. Programmed ROM with flashrom utility included in the LinuxBIOS.

6. Rebooted and had to press the reset several times to get booted.

Here after some previous problems with APPENDING the VGA bios to the
linuxbios, I had serial console attached and running on my 32-bit box.

After some period of euphoria I found on the serial console that I
have only Fallback image being loaded each time I boot tha box.

So I tried to study the problem.

Looking to the lxbios output, I found the setting

 boot_option = Fallback

in the CMOS

Changing it to Normal and reboot gives me the need to press
the reset several times and got Fallback loaded

So once more I changed the boot_option to "Normal"

Looking at the other values I'v found that there are the

      boot_first, boot_second, and boot_third

CMOS options in the lxbios output.

So I changed them to have the following lxbios output ("[lxb]" is
citation prefix):

 [lxb] boot_option = Normal
 [lxb] last_boot = Fallback
 [lxb] ECC_memory = Enable
 [lxb] baud_rate = 1200
 [lxb] hw_scrubber = Enable
 [lxb] interleave_chip_selects = Enable
 [lxb] max_mem_clock = 200Mhz
 [lxb] dual_core = Disable
 [lxb] power_on_after_fail = Disable
 [lxb] debug_level = Spew
 [lxb] boot_first = HDD
 [lxb] boot_second = Fallback_HDD
 [lxb] boot_third = Fallback_HDD
 [lxb] boot_index = 0xf
 [lxb] boot_countdown = 0x3
 [lxb] slow_cpu = off
 [lxb] nmi = Disable
 [lxb] iommu = Disable
 [lxb] lxbios: Can not read LinuxBIOS parameter user_data because layout info
 [lxb] specifies CMOS area that is too wide.

You can see the boot_first, boot_second and boot_third values there.

Rebooting once more doesn't gives new result.

Again, running under the Fallback image, I changed baud_rate CMOS
value to "115200" (since I have my serial console set to run with
115200 baude rate.

Rebooting once more, had output on Serial console With Normal image
header, but the boot process hangs early after finding dram0 not

Again, after several resets, running under the Fallback image, I found
that max_mem_clock CMOS value is set to 200Mhz (see above).
Since I have DDR400 installed, I set max_mem_clock to "400Mhz".

This time after changing boot_option to "Normal" anew (it resets to
"Fallback" each time Fallback image is loaded), I got the result
needed--now the box runs under Normal image with no problems.

That's all the story :-)

Hope it helps you if you still have problems.

Best regards,

Alexei I. Adamovich

P.S. For swapping the flash ROM chips safely, I used the "ROM chip
removal via super-glued push pins" idea presented on the linuxbios.org
front page (in upper right page corner).  It was very helpful
On Mon, Apr 23, 2007 at 11:48:48PM -0400, Ning (Michael) Qu wrote:
> I have found how to use AMIdeco from
> http://linuxbios.org/Tyan_S2882_Build_Tutorial#VGA_bios.
> But I am still now sure the other problems I asked in my last email....
>On 4/23/07, Ning (Michael) Qu <quning at gmail.com> wrote:
>> Hi, Alexei,
>> Thanks for your posts on DK8-HTX. I am just starting working on this
>> mainboard these two days. From what you said in your email, you modify
>> several things I think, and most of them must be modified by lxbios, I
>> try to summarize your work:
>> 1 serial console baud_rate -> 115200
>> 2 max_mem_clock -> 400MHz
>> 3 boot_first ("HDD"), boot_second and boot_third ("Fallback_HDD").
>> I am not sure how to achieve the third one. Is it also in cmos?
>> And another question is that I don't know how to dd a 36K Video ROM as
>> you said. Do you just enlarge the size of dd?
>> such as this?
>> dd if=/dev/mem of=vgabios.bin skip=1536 count=72
>> Is that all the things you make LinuxBIOS run on DK8-HTX? Thanks for your help!
>> Best
>> Ning

More information about the coreboot mailing list