[LinuxBIOS] lxbios bug?

Ward Vandewege ward at gnu.org
Mon Apr 23 20:49:23 CEST 2007

I've just tried running lxbios on a gigabyte m57sli-s4 board that's running
LinuxBIOS. This was the output:

  # ./lxbios -y ../LinuxBIOSv2/src/mainboard/gigabyte/m57sli/cmos.layout -a
  boot_option = Fallback
  last_boot = Fallback
  ECC_memory = Disable
  baud_rate = 1200
  hw_scrubber = Enable
  interleave_chip_selects = Enable
  max_mem_clock = 100Mhz
  dual_core = Disable
  power_on_after_fail = Disable
  # Bad value -> debug_level = 0xf
  # Bad value -> boot_first = 0x7
  boot_second = Network
  # Bad value -> boot_third = 0x4
  boot_index = 0xe
  boot_countdown = 0xfa
  # Bad value -> slow_cpu = 0xd
  nmi = Enable
  iommu = Enable
  lxbios: Can not read LinuxBIOS parameter user_data because layout info
  specifies CMOS area that is too wide.
  lxbios: Warning: LinuxBIOS CMOS checksum is bad.
As you can see there's an error at the bottom, and a bunch of 'bad value'
warnings. I first tried without passing it the cmos layout file, and got the
same result as above.

What am I doing wrong? This is lxbios 2.0.1.


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior System Administrator

More information about the coreboot mailing list