[LinuxBIOS] VGA on iwill:dk8_htx: a reqest and a question?

Alexei I. Adamovich lexa at adam.botik.ru
Thu Apr 19 08:40:49 CEST 2007


Got LB release 2587 running on iwill:dk8_htx at last.

Have a request and a question

I. Request

Please, change the section heading (and the corresponding sentence in
its contents) from

       Append VGA BIOS
       Prepend VGA BIOS


        use "cat" to concat the two images
        use "cat" to prepend VGA BIOS image to linuxbios.rom image

in the "DK8HTX Build Tutorial".

Seems this change can save a lot of time and effort to a LB
newbie. :)

BTW, here special thanks to Randall Philipson! His "Push pins" idea
is incredible!

II. Question

Had anybody got onboard VGA working on DK8-HTX?

IMHO I have done all the steps mentioned in DK8HTX Build
Tutorial--config diff attached.  But output goes only to the serial
console, no sign of life on VGA (to clarify, there is a change to get
flashrom working--#63, fix still isn't merged to the trunk?,--but VGA
doesn't live without it also).

VGA BIOS got as said (size=32K) and prepended to linuxbios.rom,
its contents starts from 55AA.

Flashrom worked fine, LB -> etherboot runs fine, Linux loaded and flying
(still haven't tried HTX card).

Maybe, I am missing something?
Have anybody any clue?

Serial console boot log attached also.

Thanks in advance,

Alexei I. Adamovich
-------------- next part --------------
diff -u -r LinuxBIOSv2-2587.orig/src/mainboard/iwill/dk8_htx/Config.lb LinuxBIOSv2-2587/src/mainboard/iwill/dk8_htx/Config.lb
--- LinuxBIOSv2-2587.orig/src/mainboard/iwill/dk8_htx/Config.lb	2007-04-15 16:50:49.000000000 +0400
+++ LinuxBIOSv2-2587/src/mainboard/iwill/dk8_htx/Config.lb	2007-04-18 13:40:18.000000000 +0400
@@ -293,10 +293,11 @@
 						device pci 0.1 on end
 						device pci 0.2 off end
 						device pci 1.0 off end
-                                                #chip drivers/pci/onboard
-                                                #        device pci 6.0 on end
-						#	register "rom_address" = "0xfff80000"
-                                                #end
+                                                chip drivers/pci/onboard
+                                                        device pci 6.0 on end
+							register "rom_address" = "0xfff80000"
+                                                end
 					device pci 1.0 on
 						chip superio/winbond/w83627hf
@@ -331,7 +332,15 @@
 								io 0x62 = 0x300
 								irq 0x70 = 9
-                	        			device pnp 2e.8 off end #  GPIO2
+#                	        			device pnp 2e.8 off end #  GPIO2
+#turned on
+							device pnp 2e.8 on  #  GPIO2
+							       io 0x07 = 0x08ff
+							       io 0x30 = 0x01ff
+							       io 0x2b = 0xd0ff
+							       io 0xf0 = 0xef16
+							end
                 	        			device pnp 2e.9 off end #  GPIO3
                 	        			device pnp 2e.a off end #  ACPI
                 	        			device pnp 2e.b on #  HW Monitor
diff -u -r LinuxBIOSv2-2587.orig/targets/iwill/dk8_htx/Config.lb LinuxBIOSv2-2587/targets/iwill/dk8_htx/Config.lb
--- LinuxBIOSv2-2587.orig/targets/iwill/dk8_htx/Config.lb	2007-04-15 16:50:58.000000000 +0400
+++ LinuxBIOSv2-2587/targets/iwill/dk8_htx/Config.lb	2007-04-18 13:33:21.000000000 +0400
@@ -10,6 +10,9 @@
 #       option ROM_SIZE = 425984 
 #       64K for Etherboot
 #        option ROM_SIZE = 458752 
+#32K for ATI ROM
+option ROM_SIZE = (512*1024)-(32*1024)
 #	option ROM_IMAGE_SIZE=0x13800
@@ -26,7 +29,8 @@
 #	payload ../../../payloads/tg3.zelf
 #	payload ../../../payloads/tg3_vga.zelf
 #	payload ../../../../payloads/tg3--filo_hda2_vga.zelf
-	payload ../../../../payloads/tg3--filo_hda2_vga_5_4.zelf
+#	payload ../../../../payloads/tg3--filo_hda2_vga_5_4.zelf
+payload ../../../../../../../payloads/e1000--filo.zelf
 #       payload ../../../../payloads/e1000--filo.zelf
 #	payload ../../../payloads/tg3_com2.zelf
 #        payload ../../../payloads/tg3--e1000--filo.zelf
@@ -53,7 +57,8 @@
 #	payload ../../../payloads/tg3_vga.zelf
 #	payload ../../../../payloads/memtest
 #	payload ../../../../payloads/tg3--filo_hda2_vga.zelf
-	payload ../../../../payloads/tg3--filo_hda2_vga_5_4.zelf
+#	payload ../../../../payloads/tg3--filo_hda2_vga_5_4.zelf
+payload ../../../../../../../payloads/tg3--filo.zelf
 #	payload ../../../payloads/tg3_com2.zelf
 #       payload ../../../../payloads/e1000--filo.zelf
 #        payload ../../../payloads/tg3--e1000--filo.zelf
-------------- next part --------------
 [LB] LinuxBIOS-2.0.0_dk8_htx_Fallback Wed Apr 18 10:09:58 MSD 2007 starting...
 [LB] *sysinfo range: [000cf000,000cf2c0)
 [LB] bsp_apicid=00
 [LB] 01 nodes initialized.
 [LB] core0 started:
 [LB] started ap apicid:
 [LB] SBLink=02
 [LB] NC node|link=02
 [LB] ht reset -
 [LB] LinuxBIOS-2.0.0_dk8_htx_Fallback Wed Apr 18 10:09:58 MSD 2007 starting...
 [LB] *sysinfo range: [000cf000,000cf2c0)
 [LB] bsp_apicid=00
 [LB] 01 nodes initialized.
 [LB] core0 started:
 [LB] started ap apicid:
 [LB] SBLink=02
 [LB] NC node|link=02
 [LB] Ram1.00
 [LB] Ram2.00
 [LB] Ram3
 [LB] Initializing memory:  done
 [LB] Ram4
 [LB] v_esp=000cefc8
 [LB] testx = 5a5a5a5a
 [LB] Copying data from cache to ram -- switching to use ram as stack... Done
 [LB] testx = 5a5a5a5a
 [LB] Disabling cache as ram now
 [LB] Clearing initial memory region: Done
 [LB] Copying LinuxBIOS to ram.
 [LB] src=fffdf000
 [LB] dst=00100000
 [LB] linxbios_ram.nrv2b length = 0000f51b
 [LB] linxbios_ram.bin   length = 00026fcc
 [LB] Jumping to LinuxBIOS.
 [LB] LinuxBIOS-2.0.0_dk8_htx_Fallback Wed Apr 18 12:52:34 MSD 2007 booting...
 [LB] Enumerating buses...
 [LB] APIC_CLUSTER: 0 enabled
 [LB] PCI_DOMAIN: 0000 enabled
 [LB]   PCI: 00:18.3 siblings=0
 [LB]         Found Rev E or Rev F later single core
 [LB] CPU: APIC: 00 enabled
 [LB] PCI: pci_scan_bus for bus 00
 [LB] PCI: 00:18.0 [1022/1100] enabled
 [LB] PCI: 00:18.1 [1022/1101] enabled
 [LB] PCI: 00:18.2 [1022/1102] enabled
 [LB] PCI: 00:18.3 [1022/1103] enabled
 [LB] PCI: 00:00.0 [1022/7450] enabled
 [LB] PCI: 00:0a.0 [1022/7450] enabled next_unitid: 000c
 [LB] PCI: 00:00.0 [1022/7460] enabled
 [LB] PCI: 00:0c.0 [1022/7460] enabled next_unitid: 0010
 [LB] PCI: pci_scan_bus for bus 00
 [LB] PCI: 00:06.0 [1022/7460] enabled
 [LB] PCI: 00:07.0 [1022/7468] enabled
 [LB] PCI: 00:07.1 [1022/7469] enabled
 [LB] PCI: 00:07.2 [1022/746a] enabled
 [LB] PCI: 00:07.3 [1022/746b] enabled
 [LB] PCI: 00:0a.0 [1022/7450] enabled
 [LB] PCI: 00:0a.1 [1022/7451] enabled
 [LB] PCI: 00:0b.0 [1022/7450] enabled
 [LB] PCI: 00:0b.1 [1022/7451] enabled
 [LB] PCI: pci_scan_bus for bus 01
 [LB] PCI: 01:00.0 [1022/7464] enabled
 [LB] PCI: 01:00.1 [1022/7464] enabled
 [LB] PCI: 01:06.0 [1002/4752] enabled
 [LB] PCI: pci_scan_bus returning with max=001
 [LB] PNP: 002e.0 disabled
 [LB] PNP: 002e.1 disabled
 [LB] PNP: 002e.2 enabled
 [LB] PNP: 002e.3 disabled
 [LB] PNP: 002e.5 enabled
 [LB] PNP: 002e.6 disabled
 [LB] PNP: 002e.7 disabled
 [LB] PNP: 002e.8 disabled
 [LB] PNP: 002e.9 disabled
 [LB] PNP: 002e.a disabled
 [LB] PNP: 002e.b enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:50 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:51 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:52 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:53 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:54 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:55 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:56 enabled
 [LB] smbus: PCI: 00:07.3[0]->I2C: 01:57 enabled
 [LB] PCI: pci_scan_bus for bus 02
 [LB] PCI: 02:03.0 [8086/1076] enabled
 [LB] PCI: 02:04.0 [8086/1076] enabled
 [LB] PCI: 02:05.0 [1095/3114] enabled
 [LB] PCI: pci_scan_bus returning with max=002
 [LB] PCI: 02: Conventional PCI
 [LB] PCI: pci_scan_bus for bus 03
 [LB] PCI: pci_scan_bus returning with max=003
 [LB] PCI: 03: 133MHz PCI-X
 [LB] PCI: pci_scan_bus returning with max=003
 [LB] PCI: pci_scan_bus returning with max=003
 [LB] done
 [LB] Allocating resources...
 [LB] Reading resources...
 [LB] PCI: 00:06.0 24 <- [0x00fff00000 - 0x00ffefffff] bus 01 prefmem
 [LB] PCI: 00:0a.0 24 <- [0xfffffffffff00000 - 0xffffffffffefffff] bus 02 prefmem
 [LB] Done reading resources.
 [LB] Allocating VGA resource PCI: 01:06.0
 [LB] Setting PCI_BRIDGE_CTL_VGA for bridge PCI: 00:06.0
 [LB] Setting PCI_BRIDGE_CTL_VGA for bridge PCI: 00:18.0
 [LB] Setting PCI_BRIDGE_CTL_VGA for bridge PCI_DOMAIN: 0000
 [LB] Setting PCI_BRIDGE_CTL_VGA for bridge Root Device
 [LB] Setting resources...
 [LB] VGA: PCI: 00:18.0 (aka node 0) link 2 has VGA device
 [LB] PCI: 00:18.0 1ba <- [0x00fd400000 - 0x00fd3fffff] prefmem <node 0 link 2>
 [LB] PCI: 00:18.0 1c2 <- [0x0000001000 - 0x0000003fff] io <node 0 link 2>
 [LB] PCI: 00:18.0 1b2 <- [0x00fc000000 - 0x00fd3fffff] mem <node 0 link 2>
 [LB] PCI: 00:06.0 1c <- [0x0000001000 - 0x0000001fff] bus 01 io
 [LB] PCI: 00:06.0 20 <- [0x00fc000000 - 0x00fd0fffff] bus 01 mem
 [LB] PCI: 01:00.0 10 <- [0x00fd000000 - 0x00fd000fff] mem
 [LB] PCI: 01:00.1 10 <- [0x00fd001000 - 0x00fd001fff] mem
 [LB] PCI: 01:06.0 10 <- [0x00fc000000 - 0x00fcffffff] mem
 [LB] PCI: 01:06.0 14 <- [0x0000001000 - 0x00000010ff] io
 [LB] PCI: 01:06.0 18 <- [0x00fd002000 - 0x00fd002fff] mem
 [LB] PCI: 01:06.0 30 <- [0x00fff80000 - 0x00fff9ffff] romem
 [LB] PNP: 002e.2 60 <- [0x00000003f8 - 0x00000003ff] io
 [LB] PNP: 002e.2 70 <- [0x0000000004 - 0x0000000004] irq
 [LB] PNP: 002e.5 60 <- [0x0000000060 - 0x0000000060] io
 [LB] PNP: 002e.5 62 <- [0x0000000064 - 0x0000000064] io
 [LB] PNP: 002e.5 70 <- [0x0000000001 - 0x0000000001] irq
 [LB] PNP: 002e.5 72 <- [0x000000000c - 0x000000000c] irq
 [LB] PNP: 002e.b 60 <- [0x0000000290 - 0x0000000297] io
 [LB] PNP: 002e.b 70 <- [0x0000000005 - 0x0000000005] irq
 [LB] PCI: 00:07.1 20 <- [0x0000003420 - 0x000000342f] io
 [LB] PCI: 00:07.2 10 <- [0x0000003400 - 0x000000341f] io
 [LB] PCI: 00:07.3 58 <- [0x0000003000 - 0x00000030ff] io
 [LB] PCI: 00:0a.0 1c <- [0x0000002000 - 0x0000002fff] bus 02 io
 [LB] PCI: 00:0a.0 20 <- [0x00fd100000 - 0x00fd2fffff] bus 02 mem
 [LB] PCI: 02:03.0 10 <- [0x00fd180000 - 0x00fd19ffff] mem
 [LB] PCI: 02:03.0 18 <- [0x0000002000 - 0x000000203f] io
 [LB] PCI: 02:04.0 10 <- [0x00fd1a0000 - 0x00fd1bffff] mem
 [LB] PCI: 02:04.0 14 <- [0x00fd1c0000 - 0x00fd1dffff] mem
 [LB] PCI: 02:04.0 18 <- [0x0000002040 - 0x000000207f] io
 [LB] PCI: 02:04.0 30 <- [0x00fd1e0000 - 0x00fd1fffff] romem
 [LB] PCI: 02:05.0 10 <- [0x0000002090 - 0x0000002097] io
 [LB] PCI: 02:05.0 14 <- [0x00000020b0 - 0x00000020b3] io
 [LB] PCI: 02:05.0 18 <- [0x00000020a0 - 0x00000020a7] io
 [LB] PCI: 02:05.0 1c <- [0x00000020c0 - 0x00000020c3] io
 [LB] PCI: 02:05.0 20 <- [0x0000002080 - 0x000000208f] io
 [LB] PCI: 02:05.0 24 <- [0x00fd200000 - 0x00fd2003ff] mem
 [LB] PCI: 02:05.0 30 <- [0x00fd100000 - 0x00fd17ffff] romem
 [LB] PCI: 00:0a.1 10 <- [0x00fd300000 - 0x00fd300fff] mem64
 [LB] PCI: 00:0b.1 10 <- [0x00fd301000 - 0x00fd301fff] mem64
 [LB] PCI: 00:18.3 94 <- [0x00f8000000 - 0x00fbffffff] mem <gart>
 [LB] Done setting resources.
 [LB] Done allocating resources.
 [LB] Enabling resources...
 [LB] PCI: 00:18.0 cmd <- 140
 [LB] PCI: 00:06.0 bridge ctrl <- 000b
 [LB] PCI: 00:06.0 cmd <- 147
 [LB] PCI: 01:00.0 subsystem <- 1022/2b80
 [LB] PCI: 01:00.0 cmd <- 142
 [LB] PCI: 01:00.1 subsystem <- 1022/2b80
 [LB] PCI: 01:00.1 cmd <- 142
 [LB] PCI: 01:06.0 subsystem <- 1022/2b80
 [LB] PCI: 01:06.0 cmd <- 1c3
 [LB] PCI: 00:07.0 subsystem <- 1022/2b80
 [LB] PCI: 00:07.0 cmd <- 14f
 [LB] w83627hf hwm smbus enabled
 [LB] PCI: 00:07.1 subsystem <- 1022/2b80
 [LB] PCI: 00:07.1 cmd <- 141
 [LB] PCI: 00:07.2 subsystem <- 1022/2b80
 [LB] PCI: 00:07.2 cmd <- 141
 [LB] PCI: 00:07.3 subsystem <- 1022/2b80
 [LB] PCI: 00:07.3 cmd <- 141
 [LB] PCI: 00:0a.0 bridge ctrl <- 0003
 [LB] PCI: 00:0a.0 cmd <- 147
 [LB] PCI: 02:03.0 cmd <- 143
 [LB] PCI: 02:04.0 cmd <- 143
 [LB] PCI: 02:05.0 cmd <- 143
 [LB] PCI: 00:0a.1 subsystem <- 1022/2b80
 [LB] PCI: 00:0a.1 cmd <- 146
 [LB] PCI: 00:0b.1 subsystem <- 1022/2b80
 [LB] PCI: 00:0b.1 cmd <- 146
 [LB] PCI: 00:18.1 subsystem <- 1022/2b80
 [LB] PCI: 00:18.1 cmd <- 140
 [LB] PCI: 00:18.2 subsystem <- 1022/2b80
 [LB] PCI: 00:18.2 cmd <- 140
 [LB] PCI: 00:18.3 cmd <- 140
 [LB] done.
 [LB] Initializing devices...
 [LB] Root Device init
 [LB] APIC_CLUSTER: 0 init
 [LB] start_eip=0x00007000, offset=0x00110000, code_size=0x0000005b
 [LB] Initializing CPU #0
 [LB] CPU: vendor AMD device 20f51
 [LB] CPU: family 0f, model 25, stepping 01
 [LB] Enabling cache
 [LB] Setting fixed MTRRs(0-88) type: UC
 [LB] Setting fixed MTRRs(0-16) Type: WB, RdMEM, WrMEM
 [LB] Setting fixed MTRRs(24-88) Type: WB, RdMEM, WrMEM
 [LB] DONE fixed MTRRs
 [LB] Setting variable MTRR 0, base:    0MB, range: 1024MB, type WB
 [LB] DONE variable MTRRs
 [LB] Clear out the extra MTRR's
 [LB] MTRR check
 [LB] Fixed MTRRs   : Enabled
 [LB] Variable MTRRs: Enabled
 [LB] CPU model AMD Opteron(tm) Processor 248
 [LB] Setting up local apic... apic_id: 0x00 done.
 [LB] Clearing memory 2048K - 1048576K: --------------- done
 [LB] CPU #0 Initialized
 [LB] All AP CPUs stopped
 [LB] PCI: 00:18.0 init
 [LB] PCI: 00:0a.0 init
 [LB] PCI: 00:06.0 init
 [LB] PCI: 01:06.0 init
 [LB] rom address for PCI: 01:06.0 = fff80000
 [LB] copying VGA ROM Image from 0xfff80000 to 0xc0000, 0x8000 bytes
 [LB] entering emulator
 [LB] halt_sys: file /home/lexa/W/LinuxBIOS/LinuxBIOSv2-2520/src/devices/emulator/x86e
 [LB] mu/ops.c, line 4387
 [LB] PCI: 00:07.0 init
 [LB] amd8111: ioapic bsp_apicid = 00
 [LB] RTC Init
 [LB] RTC: Checksum invalid zeroing cmos
 [LB] Invalid CMOS LB checksum
 [LB] enabling HPET @0xfed00000
 [LB] PNP: 002e.2 init
 [LB] PNP: 002e.5 init
 [LB] PNP: 002e.b init
 [LB] PCI: 00:07.1 init
 [LB] IDE1 IDE0 PCI: 00:07.3 init
 [LB] set power on after power fail
 [LB] pm_base: 0x3000
 [LB] PCI: 00:18.1 init
 [LB] PCI: 00:18.2 init
 [LB] PCI: 00:18.3 init
 [LB] NB: Function 3 Misc Control.. done.
 [LB] PCI: 02:03.0 init
 [LB] PCI: 02:04.0 init
 [LB] rom address for PCI: 02:04.0 = fd1e0000
 [LB] Incorrect Expansion ROM Header Signature ffff
 [LB] PCI: 02:05.0 init
 [LB] rom address for PCI: 02:05.0 = fd100000
 [LB] Incorrect Expansion ROM Header Signature ffff
 [LB] Devices initialized
 [LB] Writing IRQ routing tables to 0xf0000...setting Onboard AMD Southbridge
 [LB] Assigning IRQ 11 to 0:7.2
 [LB]   Readback = 11
 [LB] setting Onboard AMD USB
 [LB] Assigning IRQ 11 to 1:0.0
 [LB]   Readback = 11
 [LB] Assigning IRQ 11 to 1:0.1
 [LB]   Readback = 11
 [LB] done.
 [LB] ACPI: Writing ACPI tables at f0400...
 [LB] ACPI:    * HPET
 [LB] ACPI: added table 1/9 Length now 40
 [LB] ACPI:    * MADT
 [LB] ACPI: added table 2/9 Length now 44
 [LB] ACPI:    * SRAT
 [LB] SRAT: lapic cpu_index=00, node_id=00, apic_id=00
 [LB] set_srat_mem: dev PCI_DOMAIN: 0000, res->index=0010 startk=00000000, sizek=00000
 [LB] 280
 [LB] set_srat_mem: dev PCI_DOMAIN: 0000, res->index=0020 startk=00000300, sizek=000ff
 [LB] d00
 [LB] ACPI: added table 3/9 Length now 48
 [LB] ACPI:    * SLIT
 [LB] ACPI: added table 4/9 Length now 52
 [LB] ACPI:    * SSDT
 [LB] ACPI: added table 5/9 Length now 56
 [LB] ACPI:    * FACS
 [LB] ACPI:    * DSDT
 [LB] ACPI:    * DSDT @ 000f075a Length 18f1
 [LB] ACPI:    * FADT
 [LB] pm_base: 0x3000
 [LB] ACPI: added table 6/9 Length now 60
 [LB] ACPI: done.
 [LB] Wrote the mp table end at: 00000020 - 000001f0
 [LB] Moving GDT to 0x500...ok
 [LB] Wrote linuxbios table at: 00000530 - 00000de0  checksum 169b
 [LB] Welcome to elfboot, the open sourced starter.
 [LB] January 2002, Eric Biederman.
 [LB] Version 1.3
 [LB] rom_stream: 0xfffc0000 - 0xfffdefff
 [LB] Found ELF candidate at offset 0
 [LB] Loading Etherboot version: 5.2.6
 [LB] Dropping non PT_LOAD segment
 [LB] New segment addr 0x20000 size 0x62659 offset 0xb0 filesize 0xc565
 [LB] (cleaned up) New segment addr 0x20000 size 0x62659 offset 0xb0 filesize 0xc565
 [LB] Loading Segment: addr: 0x0000000000020000 memsz: 0x0000000000062659 filesz: 0x00
 [LB] 0000000000c565
 [LB] Clearing Segment: addr: 0x000000000002c565 memsz: 0x00000000000560f4
 [LB] Jumping to boot code at 0x20000
 [LB] ROM segment 0x0000 length 0x0000 reloc 0x00020000
 [LB] CPU 2279 Mhz
 [LB] Etherboot 5.2.6 (GPL) http://etherboot.org Tagged ELF for [TG3][FILO]
 [LB] Relocating _text from: [0002c570,000846a0) to [3fea7ed0,3ff00000)
 [LB] Probing pci disk... (D)isk or (Q)uit?
 [LB] [FILO]FILO version 0.4.1 (lexa at adam) Wed Apr 18 12:18:01 MSD 2007
 [LB] Press <Enter> for default boot, or <Esc> for boot prompt... timed out
 [LB] boot: hde1:/vmlinuz-2.6.17-1.2142_FC4smp console=tty0 console=ttyS0,115200 initr
 [LB] d=/initrd-2.6.17-1.2142_FC4smp.img ro root=LABEL=/mnt/sda3 rhgb
 [LB] hde: LBA48: WDC WD800JD-00LSA0
 [LB] Mounted ext2fs
 [LB] Found Linux version 2.6.17-1.2142_FC4smp (bhcompile at hs20-bc1-6.build.redhat.com)
 [LB]  #1 SMP Tue Jul 11 22:59:20 EDT 2006 bzImage.
 [LB] Loading kernel... ok
 [LB] Loading initrd... ok
 [LB] Jumping to entry point...
 [LB] Bootdata ok (command line is console=tty0 console=ttyS0,115200 ro root=LABEL=/mn
 [LB] t/sda3 rhgb)
 [LB] Linux version 2.6.17-1.2142_FC4smp (bhcompile at hs20-bc1-6.build.redhat.com) (gcc
 [LB] version 4.0.2 20051125 (Red Hat 4.0.2-8)) #1 SMP Tue Jul 11 22:59:20 EDT 2006
 [LB] BIOS-provided physical RAM map:
 [LB]  BIOS-e820: 0000000000000000 - 0000000000000e4c type 16
 [LB]  BIOS-e820: 0000000000000e4c - 00000000000a0000 (usable)
 [LB]  BIOS-e820: 00000000000f0000 - 00000000000f2400 type 16
 [LB]  BIOS-e820: 0000000000100000 - 0000000040000000 (usable)
 [LB] DMI not present or invalid.
 [LB] SRAT: PXM 0 -> APIC 0 -> Node 0
 [LB] SRAT: Node 0 PXM 0 0-a0000
 [LB] SRAT: Node 0 PXM 0 0-40000000
 [LB] ACPI: SLIT table looks invalid. Not used.
 [LB] Bootmem setup node 0 0000000000000000-0000000040000000
 [LB] ACPI: PM-Timer IO Port: 0x3008
 [LB] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
 [LB] Processor #0 15:5 APIC version 16
 [LB] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
 [LB] ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
 [LB] IOAPIC[0]: apic_id 1, version 17, address 0xfec00000, GSI 0-23
 [LB] ACPI: IOAPIC (id[0x02] address[0xfd300000] gsi_base[24])
 [LB] IOAPIC[1]: apic_id 2, version 17, address 0xfd300000, GSI 24-27
 [LB] ACPI: IOAPIC (id[0x03] address[0xfd301000] gsi_base[28])
 [LB] IOAPIC[2]: apic_id 3, version 17, address 0xfd301000, GSI 28-31
 [LB] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
 [LB] Setting APIC routing to physical flat
 [LB] ACPI: HPET id: 0x102282a0 base: 0xfed00000
 [LB] Using ACPI (MADT) for SMP configuration information
 [LB] Allocating PCI resources starting at 50000000 (gap: 40000000:c0000000)
 [LB] Checking aperture...
 [LB] CPU 0: aperture @ f8000000 size 64 MB
 [LB] SMP: Allowing 1 CPUs, 0 hotplug CPUs
 [LB] Built 1 zonelists
 [LB] Kernel command line: console=tty0 console=ttyS0,115200 ro root=LABEL=/mnt/sda3 r
 [LB] hgb
 [LB] Initializing CPU#0
 [LB] PID hash table entries: 4096 (order: 12, 32768 bytes)
 [LB] time.c: Using 14.318180 MHz WALL HPET GTOD HPET/TSC timer.
 [LB] time.c: Detected 2205.084 MHz processor.
 [LB] Console: colour dummy device 80x25
 [LB] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
 [LB] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
 [LB] Memory: 1024744k/1048576k available (2380k kernel code, 23444k reserved, 1756k d
 [LB] ata, 200k init)
 [LB] Calibrating delay using timer specific routine.. 4416.66 BogoMIPS (lpj=8833322)
 [LB] Security Framework v1.0.0 initialized
 [LB] SELinux:  Initializing.
 [LB] SELinux:  Starting in permissive mode
 [LB] selinux_register_security:  Registering secondary module capability
 [LB] Capability LSM initialized as secondary
 [LB] Mount-cache hash table entries: 256
 [LB] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
 [LB] CPU: L2 Cache: 1024K (64 bytes/line)
 [LB] CPU 0/0(1) -> Node 0 -> Core 0
 [LB] Using local APIC timer interrupts.
 [LB] result 12528886
 [LB] Detected 12.528 MHz APIC timer.
 [LB] Brought up 1 CPUs
 [LB] testing NMI watchdog ... OK.
 [LB] checking if image is initramfs... it is
 [LB] Freeing initrd memory: 1187k freed
 [LB] NET: Registered protocol family 16
 [LB] ACPI: bus type pci registered
 [LB] PCI: Using configuration type 1
 [LB] ACPI: Subsystem revision 20060127
 [LB] ACPI: Interpreter enabled
 [LB] ACPI: Using IOAPIC for interrupt routing
 [LB] ACPI: PCI Root Bridge [PCI0] (0000:00)
 [LB] ACPI: PCI Interrupt Link [LNKA] (IRQs *3 5 10 11)
 [LB] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 *5 10 11)
 [LB] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 5 *10 11)
 [LB] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 5 10 *11)
 [LB] Linux Plug and Play Support v0.97 (c) Adam Belay
 [LB] pnp: PnP ACPI init
 [LB] pnp: PnP ACPI: found 9 devices
 [LB] usbcore: registered new driver usbfs
 [LB] usbcore: registered new driver hub
 [LB] PCI: Using ACPI for IRQ routing
 [LB] PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
 [LB] hpet0: at MMIO 0xfed00000 (virtual 0xffffffffff5fe000), IRQs 2, 8, 0
 [LB] hpet0: 3 32-bit timers, 14318180 Hz
 [LB] PCI-DMA: Disabling IOMMU.
 [LB] pnp: 00:06: ioport range 0x4d0-0x4d1 has been reserved
 [LB] pnp: 00:06: ioport range 0x1100-0x117f has been reserved
 [LB] pnp: 00:06: ioport range 0x1180-0x11ff has been reserved
 [LB] PCI: Bridge: 0000:00:06.0
 [LB]   IO window: 1000-1fff
 [LB]   MEM window: fc000000-fd0fffff
 [LB]   PREFETCH window: 50000000-500fffff
 [LB] PCI: Bridge: 0000:00:0a.0
 [LB]   IO window: 2000-2fff
 [LB]   MEM window: fd100000-fd2fffff
 [LB]   PREFETCH window: disabled.
 [LB] PCI: Bridge: 0000:00:0b.0
 [LB]   IO window: disabled.
 [LB]   MEM window: disabled.
 [LB]   PREFETCH window: disabled.
 [LB] NET: Registered protocol family 2
 [LB] IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
 [LB] TCP established hash table entries: 131072 (order: 10, 4194304 bytes)
 [LB] TCP bind hash table entries: 65536 (order: 9, 2097152 bytes)
 [LB] TCP: Hash tables configured (established 131072 bind 65536)
 [LB] TCP reno registered
 [LB] IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
 [LB] audit: initializing netlink socket (disabled)
 [LB] audit(1104538891.808:1): initialized
 [LB] Total HugeTLB memory allocated, 0
 [LB] VFS: Disk quotas dquot_6.5.1
 [LB] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
 [LB] SELinux:  Registering netfilter hooks
 [LB] Initializing Cryptographic API
 [LB] ksign: Installing public key data
 [LB] Loading keyring
 [LB] - Added public key 8962EFD9AF4DD423
 [LB]   - key was been created 48133021 seconds in future
 [LB] - User ID: Red Hat, Inc. (Kernel Module GPG key)
 [LB] io scheduler noop registered
 [LB] io scheduler anticipatory registered
 [LB] io scheduler deadline registered
 [LB] io scheduler cfq registered (default)
 [LB] PCI: MSI quirk detected. PCI_BUS_FLAGS_NO_MSI set for subordinate bus.
 [LB] PCI: MSI quirk detected. PCI_BUS_FLAGS_NO_MSI set for subordinate bus.
 [LB] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
 [LB] ACPI: Processor [CPU0] (supports 8 throttling states)
 [LB] Real Time Clock Driver v1.12ac
 [LB] Non-volatile memory driver v1.2
 [LB] Linux agpgart interface v0.101 (c) Dave Jones
 [LB] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
 [LB] ?serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
 [LB] isa bounce pool size: 16 pages
 [LB] RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
 [LB] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
 [LB] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
 [LB] AMD8111: IDE controller at PCI slot 0000:00:07.1
 [LB] AMD8111: chipset revision 3
 [LB] AMD8111: not 100% native mode: will probe irqs later
 [LB] AMD8111: 0000:00:07.1 (rev 03) UDMA133 controller
 [LB]     ide0: BM-DMA at 0x3420-0x3427, BIOS settings: hda:pio, hdb:pio
 [LB]     ide1: BM-DMA at 0x3428-0x342f, BIOS settings: hdc:pio, hdd:pio
 [LB] ide-floppy driver 0.99.newide
 [LB] usbcore: registered new driver libusual
 [LB] usbcore: registered new driver hiddev
 [LB] usbcore: registered new driver usbhid
 [LB] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
 [LB] PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
 [LB] PNP: PS/2 controller doesn't have AUX irq; using default 12
 [LB] serio: i8042 AUX port at 0x60,0x64 irq 12
 [LB] serio: i8042 KBD port at 0x60,0x64 irq 1
 [LB] mice: PS/2 mouse device common for all mice
 [LB] md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
 [LB] md: bitmap version 4.39
 [LB] TCP bic registered
 [LB] Initializing IPsec netlink socket
 [LB] NET: Registered protocol family 1
 [LB] NET: Registered protocol family 17
 [LB] powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.60.2)
 [LB] powernow-k8: BIOS error - no PSB or ACPI _PSS objects
 [LB] ACPI wakeup devices:
 [LB] ACPI: (supports S0 S1 S3 S5)
 [LB] Freeing unused kernel memory: 200k freed
 [LB] Write protecting the kernel read-only data: 958k
 [LB] Red Hat nash version 4.2.15 starting
 [LB] Mounted /proc filesystem
 [LB] Mounting sysfs
 [LB] Creating /dev
 [LB] Starting udev
 [LB] Loading scsi_mod.ko module
 [LB] SCSI subsystem initialized
 [LB] Loading sd_mod.ko module
 [LB] Loading libata.ko module
 [LB] Loading sata_sil.ko module
 [LB] GSI 16 sharing vector 0xA9 and IRQ 16
 [LB] ACPI: PCI Interrupt 0000:02:05.0[A] -> GSI 25 (level, low) -> IRQ 169
 [LB] sata_sil 0000:02:05.0: Applying R_ERR on DMA activate FIS errata fix
 [LB] ata1: SATA max UDMA/100 cmd 0xFFFFC20000010080 ctl 0xFFFFC2000001008A bmdma 0xFF
 [LB] FFC20000010000 irq 169
 [LB] ata2: SATA max UDMA/100 cmd 0xFFFFC200000100C0 ctl 0xFFFFC200000100CA bmdma 0xFF
 [LB] FFC20000010008 irq 169
 [LB] ata3: SATA max UDMA/100 cmd 0xFFFFC20000010280 ctl 0xFFFFC2000001028A bmdma 0xFF
 [LB] FFC20000010200 irq 169
 [LB] ata4: SATA max UDMA/100 cmd 0xFFFFC200000102C0 ctl 0xFFFFC200000102CA bmdma 0xFF
 [LB] FFC20000010208 irq 169
 [LB] input: AT Translated Set 2 keyboard as /class/input/input0
 [LB] ata1: SATA link up 1.5 Gbps (SStatus 113)
 [LB] ata1: dev 0 ATA-7, max UDMA/133, 156301488 sectors: LBA48
 [LB] ata1: dev 0 configured for UDMA/100
 [LB] scsi0 : sata_sil
 [LB] ata2: SATA link down (SStatus 0)
 [LB] scsi1 : sata_sil
 [LB] ata3: SATA link down (SStatus 0)
 [LB] scsi2 : sata_sil
 [LB] ata4: SATA link down (SStatus 0)
 [LB] scsi3 : sata_sil
 [LB]   Vendor: ATA       Model: WDC WD800JD-00LS  Rev: 06.0
 [LB]   Type:   Direct-Access                      ANSI SCSI revision: 05
 [LB] SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
 [LB] sda: Write Protect is off
 [LB] SCSI device sda: drive cache: write back
 [LB] SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
 [LB] sda: Write Protect is off
 [LB] SCSI device sda: drive cache: write back
 [LB]  sda: sda1 sda2 sda3 sda4 < sda5 sda6 >
 [LB] sd 0:0:0:0: Attached scsi disk sda
 [LB] Creating root device
 [LB] Mounting root filesystem
 [LB] Switching to new root
 [LB] unmounting old /proc
 [LB] unmounting old /sys
 [LB] SELinux:  Disabled at runtime.
 [LB] SELinux:  Unregistering netfilter hooks
 [LB] audit(1104538896.244:2): selinux=0 auid=4294967295
 [LB] INIT: version 2.85 booting
 [LB]                 Welcome to Fedora Core
 [LB]                 Press 'I' to enter interactive startup.
 [LB] Starting udev:[  OK  ]
... and so on until
 [LB] ... login:

More information about the coreboot mailing list