[LinuxBIOS] epia memory issues

Ben Hewson ben at hewson-venieri.com
Sun Sep 10 11:12:23 CEST 2006

ron minnich wrote:
> Your memory is still wrong.
> 0x67 ... oh boy. I am working from memory here. At some point the
> chipset added two more DBR registers -- I wonder if this is it.
> Sorry but it's been 6 years ...  I will try to find my books and see
> what that might be.
> thanks
> ron

I think maybe reg 0x67 is misleading. I have a feeling that the problem 
may not be with the configuration of the northbridge, but more to do
with timing. Currently I am setting reg 0x67 at the end of
sdram_set_registers(). If it is there the boot process gets further. If
I take it out I get errors with something else, can't remember what
exactly. I need to test if the extra delay is meaningful all be it very
short, or if writing to the register is actually doing something. I
originally tried setting reg 0x67 further down inside sdram_enable() but
it did not have any effect there. Of course that could just mean it
needs to be set earlier.

As far as I can see reg 0x67 has never been set in any of the version of
Linuxbios I have looked at, and as it has worked in the past I think it
is probably not important. Just because the original bios is setting it,
doesn't mean that it is right either.

Who wrote the original vt8601 code ? The vt8601a datasheet makes mention
of "VT8601A BIOS porting guide" but I can't find it anywhere. Perhaps I
will have to email VIA and see if they would be good enough to send me a

More information about the coreboot mailing list