[LinuxBIOS] Question about AMD/Cyrix Geode GX1 based system

Juergen Beisert juergen127 at kreuzholzen.de
Mon May 29 17:46:49 CEST 2006

Hi all,

I am trying to bring up a small WinCE based terminal with LinuxBios instead. 
I'm using the eaglelion/5bcm as a starting point. With this the system comes 
up, starts etherboot, etherboot loads my Linux kernel (up to text "....done") 
and then nothing more happens.

Some things confuses me: 

Devices initialized
Copying IRQ routing tables to 0xf0000...done.
Verifing copy of IRQ routing tables at 0xf0000...failed
Wrote linuxbios table at: 00000000 - 0000017c  checksum 2df2

I read in the archives that this failure could be solved be undefining 
CONFIG_COMPRESS. But it did'nt help. Any other hint to solve it?

When etherboot starts:

Etherboot 5.4.2 (GPL) http://etherboot.org
Drivers: RTL8139   Images: ELF
Protocols: DHCP TFTP
Relocating _text from: [000100e0,000219a0) to [03aee740,03b00000)
Boot from (N)etwork or (Q)uit?

Probing pci nic...
[rtl8139] - ioaddr 0X1000, irq 0, addr 00:30:AA:00:25:1B 100Mbps full-duplex
Searching for server (DHCP).....
Me:, DHCP:, TFTP:, Gateway
Loading ..(ELF)..

Is "irq 0" correct at this point of time?

Does LinuxBIOS needs any preparations/patches on the Linux kernel to boot and 
run it?
I tried with enabled framebuffer console (and activated screen in the Geode) 
and with console on serial port. Both without success (also I tried 2.4 and 
2.6 kernels).

Thanks for any help in advance.


More information about the coreboot mailing list