[LinuxBIOS] Etherboot (FILO) with SATA on tyan s2895

Myles Watson myles at pel.cs.byu.edu
Thu May 18 15:48:40 CEST 2006

It's starting to seem like a long chain of events from LinuxBIOS to
Etherboot to FILO to kernel on CF to myKernel.  I'd also like to be able to
get to grub eventually.  Is there a way to go from LinuxBIOS to grub more
directly on the s2895?

Thanks again for your help.


-----Original Message-----
From: Lu, Yinghai [mailto:yinghai.lu at amd.com] 
Sent: Wednesday, May 17, 2006 5:09 PM
To: myles at mouselemur.cs.byu.edu; linuxbios at linuxbios.org
Subject: RE: [LinuxBIOS] Etherboot (FILO) with SATA on tyan s2895

You can not boot from CK804 sata directly with FILO in Etherboot.

The code only support Sata that can work on compatible IDE mode. 

You need to use other media ( network, CF IDE flash) to load kernel with
ck804 sata and kexec support, and use kexec to load final kernel in your
sata disk.


-----Original Message-----
From: linuxbios-bounces at linuxbios.org
[mailto:linuxbios-bounces at linuxbios.org] On Behalf Of Myles Watson
Sent: Wednesday, May 17, 2006 3:57 PM
To: linuxbios at linuxbios.org
Subject: [LinuxBIOS] Etherboot (FILO) with SATA on tyan s2895

I am booting linuxbios with etherboot and filo as the payload. I tried
follow the s2881 tutorial on the wiki.

Etherboot only finds my cd-rom. When I try to use hde:/ it tells me that
"Drive 4 does not exist". All drives up to j except hda (my cd-rom) give
same error message. Sometimes if I try hdg it hangs.

I saw README.filo_in_etherboot where it says it only works on SATA port
1 or
2. I've tried on SATA 0 port 0 and 1, SATA 1 port 2 and 3.

I also seem to need to boot the factory BIOS in between each attempt, or
won't get very far.

Is there something simple I've missed?



Etherboot 5.4.2
Drivers: TG3 FILO Images: NBI ELF
Protocols: DHCP TFTP
Relocating text ...
Scanning PCI: found 30 devices
Probing pci disk...
[FILO]FILO version 0.4.1
boot: hde3:/boot/vmlinuz... initrd=/boot/initrd...
IDE time out
No drive detected on IDE channel 2
boot: hdc:/ 
No drive detected on IDE channel 1

linuxbios mailing list
linuxbios at linuxbios.org

More information about the coreboot mailing list