[LinuxBIOS] Etherboot (FILO) with SATA on tyan s2895

Myles Watson myles at pel.cs.byu.edu
Thu May 18 00:57:02 CEST 2006

I am booting linuxbios with etherboot and filo as the payload. I tried to
follow the s2881 tutorial on the wiki.

Etherboot only finds my cd-rom. When I try to use hde:/ it tells me that
"Drive 4 does not exist". All drives up to j except hda (my cd-rom) give the
same error message. Sometimes if I try hdg it hangs.

I saw README.filo_in_etherboot where it says it only works on SATA port 1 or
2. I've tried on SATA 0 port 0 and 1, SATA 1 port 2 and 3.

I also seem to need to boot the factory BIOS in between each attempt, or I
won't get very far.

Is there something simple I've missed?



Etherboot 5.4.2
Drivers: TG3 FILO Images: NBI ELF
Protocols: DHCP TFTP
Relocating text ...
Scanning PCI: found 30 devices
Probing pci disk...
[FILO]FILO version 0.4.1
boot: hde3:/boot/vmlinuz... initrd=/boot/initrd...
IDE time out
No drive detected on IDE channel 2
boot: hdc:/ 
No drive detected on IDE channel 1

More information about the coreboot mailing list