[LinuxBIOS] EPIA non-M?

Alex Mauer hawke at hawkesnest.net
Thu May 18 00:04:05 CEST 2006

Alex Mauer wrote:
> So I tried just pulling src/northbridge/via/vt8601/raminit.c in from
> each of those revisions.
> None of them got past the jump to LinuxBIOS.

Alright, more info now.  I worked with Richard Smith for awhile, and did
the following using the latest BIOS available.  (my #defines were set at
reasonably conservative settings, and were fine for my board)

Enabled a call to ram_check.

Got the LB northbridge RAM configuration to be the same as it is for the
factory BIOS, to the extent possible, based on the datasheet for the
vt8601a and output of 'lspci -xxx'

Results from the ram_check seem to show that the ram is not being
properly intialized and/or refreshed.  I checked an area from 0x20000
through 0x21000.  As the ram check progresses, it starts out reading
values 0x0002ffcc, then gradually drops until it reads 0x00020000 and
finally 0x00000000.

At this point I'm rather stuck.

Ron (or anyone else, really), do you have a chance to look at this
and/or advise me on things I can do/try in order to get this working
again?  I can provide output from my test system, and am happy to test
as needed.

Thanks much

-Alex Mauer "hawke"

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20060517/c0a5311f/attachment.sig>

More information about the coreboot mailing list