[LinuxBIOS] Epia M tree build issue

Eric Poulsen eric at zyxod.com
Thu May 4 18:31:24 CEST 2006

I know I'm beginning to sound like a broken record here, but I can't 
seem to get a definitive answer, and the build process for LB is ... 

1) Is the effect reproducible on other systems? Has anyone else tried to 
follow the same steps I have?*
2) If so, is this a "real" issue?  Or do I just badly mis-understand the 
LB build process?

* I realize that most people don't have Epia motherboards to try this 
on, but if the "right" way compiles the first time around, that'd be 


The issue: There are two distinct ways I've attempted to build an Epia-M 

The first way I tried it was "wrong" because I didn't do a 'make clean' 
after changing config options and re-running 'builtarget'. Oddly, this 
"wrong" way resulted in a working LB install.

Later, when modifying LB itself to better support the Epia ML (NB: These 
changes have no affect on the effect seen, and everything mentioned here 
applies to a stock Epia M target), I was more careful about my build 
process, and found that building from fully cleaned ('make clean') 
target directory resulted in a LB binary that did not work.

The "wrong" way that works:

'buildtarget via/epia-m'
[compiles OK, but we don't have VGA options]
Edit Config.lb; add the vga options (CONFIG_CONSOLE_VGA=1, 
'buildtarget via/epia-m'
[Compiles successfully -- We now have a working LB + VGA ]
[If you do a "make clean" just before the _second_ make, you'll have the 
same linking errors you see below]

The "right" way that doesn't work:

Enter the targets/via/epia-m directory
Edit Config.lb; add the vga options (CONFIG_CONSOLE_VGA=1, 
'buildtarget via/epia-m'
[Linking errors -- I'd say this is where the issue first manifests itself]
Edit Config.lb again, increase ROM_IMAGE_SIZE
'buildtarget via/epia-m'
[Compiles successfully, but with a bad LB image -- Exception 13 during 
attempts to init VGA]

More information about the coreboot mailing list