[LinuxBIOS] Old L440GX is it still bootable under LinuxBios

Richard Smith smithbone at gmail.com
Mon Mar 13 20:33:01 CET 2006

On 3/12/06, ron minnich <rminnich at gmail.com> wrote:

> You'll just have to get the LinuxBIOS v1 and try it. I don't know any more
> -- last 440GX I worked on was
>  5 years ago!

I re-worked some of the memory detection routines for the 440BX.  A
lot of it came from the 440GX code that was in the tree when I
started.  IIRC there were some bit polarity issues when talking to the
smbus controller.  I've never looked at a GX datasheet so I don't know
if it was a bug or if they switched things for the BX.

The v1 code may work but if it dosen't you might want to compare the
routines with the code in the bitworks mainboard directory and give
them a try.

Somewhere in that compile chain I think there is problem with newer
gcc's so if it chokes then you may have to tweak the makefiles to use
gcc-2.95.  (or fix the code)

Richard A. Smith

More information about the coreboot mailing list