[LinuxBIOS] EPIA-MII 12000, almost there. ( newbie )

Richard Smith smithbone at gmail.com
Wed Jun 14 18:27:55 CEST 2006

On 6/14/06, Per Mellander <per at mellander.org> wrote:

> Thank you, thank you, thank you for those words!
> I was nearly giving up today after trying 64k of zero's instead of VGA and nothing
> worked. I was almost certain that I'm to stupid to do this ;)

Hmm... That should have worked.

The issue is that the buildsystem is creating a rom file that is 64k
shy of the size of your ROM part.  So all the addresses in the part
will all be 64k lower than where they need to be.

You can solve this by either prepending 64k data that bumps the size
of the rom file up to the size of the rom part, or program the file
into the part with a 64k offset.

So regardless if you used 0x00's, 0xff, or random bytes you should
still get _some_ serial output if the size is correct.

You can check your rom file with the following.

'hd -s 255k <romfile>'

If you don't see an 0xe9 at address 0x0003fff0 then your rom file is not valid.

Richard A. Smith

More information about the coreboot mailing list