[LinuxBIOS] EPIA-MII 12000, almost there. ( newbie )

Per Mellander per at mellander.org
Mon Jun 12 13:55:41 CEST 2006

On Sat, 10 Jun 2006 10:11:28 -0600, ron minnich wrote
> 1) when booting linuxbios on a new machine, ALWAYS configure the
>     kernel as an i386. It's just safer that way. Turn off everything you
> can.
>     make sure what you're doing would work on a 1990-era PC.

Tried with a pure i386-kernel, same result :(

> 2) always enable serial and, before you try linuxbios, run
>     minicom on the machine and make sure serial REALLY works.
>     This is also a good cable test. Take nothing for granted.

It works alright! Has been running it from day one ;)

> 3) If it's legal where you live,
>     always burn a copy of the fuctory bios and boot with that,
>     to ensure your burn path is totally working.
>     Again, if it is legal where you live, keep a spare
>     copy of fuctory bios around for that inevitable time when you
>     screw up and flash over it.

I've got a BIOS-savior, and I run the BIOS in that. I don't think it will make any
difference pulling the savior out and place LB in the original socket.

> 4) never try VGA on the first time around. It adds too much
>     variation

I'm not quite sure how to manage that. Everytime I've tried just leaving out the "cat 
/root/113mem.bin fallback/linuxbios.rom > ./linuxbios.rom" I end up with a nonbootable
prom. Is there any other changes to be done to make it work?

> 5) use earlyprintk! earlyprintk=ttyS0,115200,keep

Tried that, no special output at all. ( See below. ) What I did was to make sure kernel
is compiled with CONFIG_EARLY_PRINTK=y and adding the above line to my commandline:

mkelfImage --kernel=/boot/vmlinuz- \
           --output=/vmlinuz-i386-ep.elf \
           --initrd=/boot/initrd- \
           --command-line="ro root=LABEL=/ rhgb quiet console=tty0 console=ttyS0,115200


Jumping to boot code at 0x109ad4
FILO version 0.5 (root at mm.int.mmtab.se) Wed May 31 13:44:15 CEST 2006
Press <Enter> for default boot, or <Esc> for boot prompt...  
boot: hda1:/vmlinuz-i386-ep.elf
find_ide_controller: found PCI IDE controller 1106:0571 prog_if=0x8a
find_ide_controller: primary channel: compatibility mode
find_ide_controller: cmd_base=0x1f0 ctrl_base=0x3f4
ide_software_reset: Waiting for ide0 to become ready for reset... ok
init_drive: Testing for hda
init_drive: Probing for hda
init_drive: LBA mode, sectors=268435455
init_drive: LBA48 mode, sectors=321672960
init_drive: Init device params... ok
hda: LBA48 164GB: HDS722516VLAT80                         
Mounted ext2fs
Loading Linux version (root at mm.int.mmtab.se) #4 Mon Jun 12 10:46:16 CEST
Jumping to entry point...


> 6) learn to use initramfs, and have it boot a simple shell
>     (I'm just getting the hang of this, but it's very useful)
>     (you can write a shell in surprisingly small space)

I'd love to, as soon as I can get the kernel to load at all.

> 7) spontaneous reboots almost always mean that
>    you have the wrong cpu type. See note (1) above.
>    very quick reboots are a good hint that memory is
>    getting errors. Lockups are a sign of bad memory
>    programming (you wouldn't believe some  of the failures
>    I've seen) or you've got an old VIA chipset with a bug :-)
>    For any but the worst reboots, earlyprintk is a big help.

[root at mm linux-]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 82)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 82)
00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC
Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97
Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo CLE266]
integrated CastleRock graphics (rev 03)

[root at mm linux-]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 8
cpu MHz         : 1199.924
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr cx8 mtrr pge cmov pat mmx fxsr sse rng rng_en
ace ace_en
bogomips        : 2403.34


More information about the coreboot mailing list