[LinuxBIOS] Build problem

Richard Smith smithbone at gmail.com
Fri Jul 14 17:19:30 CEST 2006

> Hi I am new to LinuxBIOS. I am using LinuxBIOSv2 .I am trying to build a rom


> #cd LinuxBIOSv2/targets/
> #./buildtarget newisys/khepri
> #cd newisys/khepri/khepri
> #make
> I get the following error -
> linuxbios_ram.o(.text+0x853c): In function `start_cpu':
> : undefined reference to `_secondary_start'
> collect2: ld returned 1 exit status
> make[1]: *** [linuxbios_ram] Error 1

I don't have your hardware but I just tried the build and it worked
fine for me.  I got all the way to the payload error which is the last


_secondary_start looks to me to be code that will start up the other
cpus in SMP.  Its assmembly that lives

'src/cpu/x86/lapic/lapic_cpu_init.c' copies that code into a area below 1M.

Unless this is your truly first attempt to build this then you should
do is a fresh check out into a new directory and re-try.  I've had
buildproblems with unresolved symbols in the past that were fixed by
clean checkouts.  The linuxbios build system is pretty complex and
sometimes it can get confused.

If you still have the problem after that then save the build info to a
file and grep through it looking for where secondary.S is assembled
and make sure it's making it into your linker statements.

Richard A. Smith

More information about the coreboot mailing list