[LinuxBIOS] Build issue for khepri target

Anil B G bg.anil at gmail.com
Wed Jul 12 16:58:04 CEST 2006

  I am new to LinuxBIOS. I downloaded the latest snapshot of LinuxBIOSv2 and
tried building it for a couple of boards (newisys/intel etc).
I was able to build it for intel but when I tried to build it for
newisys/khepri I got the following error:

gcc -o buildrom /home/anil/LinuxBios/LinuxBIOSv2/util/buildrom/buildrom.c
./buildrom linuxbios.strip linuxbios.rom payload 0x20000 0x20000
payload (77000) + linuxbios (131072) size larger than ROM (131072) size!
make[1]: *** [linuxbios.rom] Error 1
make[1]: Leaving directory
make: *** [fallback/linuxbios.rom] Error 1
I disabled the fallback option and then was able to get the khepri.rom whose
size was 384K. I am using the FILO as the payload.
Is the size of 384K fine? Has any one used LinuxBIOSv2 on khepri? Would
appreciate any help.
Pls. let me know if any addl. info is reqd.

The gcc version is 3.4.3

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20060712/7be8d06f/attachment.html>

More information about the coreboot mailing list