[LinuxBIOS] Success report on VIA EPIA-M10000

Leon Woestenberg leonw at mailcan.com
Sat Feb 25 14:30:17 CET 2006

Hello Ron,

first my *unchanged* 2177 already worked in the console, but did make it 
into X; it reported:

VIA(0): Bad V-BIOS checksum.

Chris Suehs then responded to me off-list (Thanks Chris!):
I have had the same problem for the via X driver.
There is a failure in the LinuxBios Code for newer Epia M

The vga bios section is not write protected, because the protection
failt for a false Device ID

You should try to change the code to the right ID in mainboard.c for the 
Epia to 3122 in the write_protect_vgabios function

regards chris

So I tried again with 2184 and this single change and it worked; I get 
into my X server without a hiss now.

ron minnich wrote:
> This is intriguing.
> -     dev = dev_find_device(PCI_VENDOR_ID
> _VIA, 0x3123, 0);
> +     dev = dev_find_device(PCI_VENDOR_ID_VIA, 0x3122, 0);
> I think what this means is that we need a new mainboard directory. can 
> you give me more info about the exact mainboard.
> Another option, is to do something like tihs:
> dev = dev_find_device(PCI_VENDOR_ID_VIA, 0x3123, 0);
> if (! dev)
>     dev = dev_find_device(PCI_VENDOR_ID_VIA, 0x3122, 0);
> or some such. But if you could tell us the exact vendor etc. that 
> would be good to know.
Ron, what exactly do you want to know further than this?

VIA EPIA-M10000, PCB revision.B

I could output lspci -vv or so if that helps?


Leon Woestenberg.

More information about the coreboot mailing list