[LinuxBIOS] #65: Unify SuperIO code?

LinuxBIOS svn at openbios.org
Thu Dec 14 01:22:49 CET 2006

#65: Unify SuperIO code?
   Reporter:  stepan             |          Owner:  somebody      
       Type:  enhancement        |         Status:  new           
   Priority:  minor              |      Milestone:  Cosmetic fixes
  Component:  code               |        Version:  v2            
   Keywords:                     |   Dependencies:                
Patchstatus:  there is no patch  |  
 One thing I've been noticing in the current superio implementations: A lot
 of differences come from having the part names used in variable and macro
    #define FDC37M60X_CONFIG_REG_CC 0x02

 Maybe we should change that to some unique names

    #define SUPERIO_CONFIG_REG_CC 0x02

  * Those names are usually file local only, so name clashes wont be a
  * They are the same for most (all?) SuperIOs?

 Doing so (maybe with function names as well?) would unify the superio
 interface, or at least make diffing the code of different devices a bit

Ticket URL: <http://tracker.linuxbios.org/trac/LinuxBIOS/ticket/65>
LinuxBIOS <http://www.linuxbios.org/>

More information about the coreboot mailing list