[LinuxBIOS] Booting LinuxBIOS on an EPIA-V

Richard Smith smithbone at gmail.com
Fri Aug 25 04:50:06 CEST 2006

On 8/24/06, Fredrik Tolf <fredrik at dolda2000.com> wrote:
> It was indeed set to 115200 N81, but I just experimented a bit and found
> that it worked on 19200 baud (with some garbage at the top, though). :)

Oh thats right.. There is some freaky divider issue with the EPIA...
Need to document that somewhere.

> Slot 00 is SDRAM 08000000 bytes ^M$
> 0100 is the chip size^M$
> 000e is the MA type^M$
> Slot 01 is empty^M$
> Slot 02 is empty^M$
> Slot 03 is empty^M$
> vt8601 done^M$
> Copying LinuxBIOS to ram.^M$
> Jumping to LinuxBIOS.^M$
> I guess that's a pretty good indication that RAM isn't working, right?

Yeah.  Look in the code and you will find a simple RAM test.  It will
show lots of bit errors and then total failure.

> So to get back to debugging this, do you have any idea of a time when
> the 8601 code was working?

Sorry no.. You will just have to go through the entire log and pull
revs all revs that deal with the 8601.  Sorry I don't have any more
info.  Most of the people who worked on that don't seem to be on the
list anymore.

 Was it while LinuxBIOS existed in Subversion
> (there was a CVS repo some years ago, wasn't there)?

Right but Stefan back ported all the stuff to svn.

Richard A. Smith

More information about the coreboot mailing list