[LinuxBIOS] Booting LinuxBIOS on an EPIA-V

Fredrik Tolf fredrik at dolda2000.com
Thu Aug 24 01:52:01 CEST 2006

Hi list!

I've been trying to get LinuxBIOS to boot on my EPIA-V motherboard (VIA
8601A NB, VT8231 SB), and at first I followed the bundled HOWTO for the
EPIA-M, before I discovered that EPIA-V was an entirely different
creatures (it uses SDRAM, whereas I believe that the EPIA-M uses DDRAM),
and the EPIA-M BIOS didn't boot, of course.

However, I've tried a number of different variations of the via/epia
configuration now, and it doesn't seem to want to boot whatever I do.
The new flash chip I used is a 512 KiB chip, as opposed to the original
256 KiB chip (which isn't a problem, though, because if I burn the
original BIOS to it with a 256 KiB block from /dev/zero prepended to it,
it boots just fine), so I tried the 512kbflash config file as well, but
to no avail.

I'm using FILO as the payload.

I'm beginning to run out of options, and I don't know how to diagnose
LinuxBIOS. The monitor doesn't turn on, so I'm guessing it might be
something to do with the VGA BIOS. In the EPIA-M HOWTO it said to
prepend the LinuxBIOS image with the original 64 KiB VGA BIOS image --
is that the same for the EPIA-V (and in that case, how would I do to
generate a LinuxBIOS image that is suitable for prepending with the VGA

Thank you for your time!

Fredrik Tolf

More information about the coreboot mailing list