[LinuxBIOS] RD1-PL on EPIA-M10000 problem

Ben Hewson ben at hewson-venieri.com
Wed Aug 9 19:38:39 CEST 2006

I had alot of problems with the RD1 bios savior on my EPIA5000 board. I
lost track of the times I tried to flash it, it certainly seemed alot
more than 10 times. In the end I wrote a small script to just sit there
and try and flash the RD1 bios until it verified. It actually worked on
the 5th attempt. I now have the original bios in the RD1 flash and am
using the on-board flash for linuxbios (although it does not boot yet).
The on-board flash, programs first time. There is a note on the
Linuxbios web site about the RD1 bios savior and the fact that it
doesn't program very well. Of course the EPIA-M has a different chipset
so there may be other problems, but I suspect it is just down to the
flash on the RD1.


> * lists at actweb.info <lists at actweb.info> [060809 01:49]:
>>  i have an EPIA-M m/board with an SST39SF020A bios chip, along with an
>>  RD1-PL 2Mbit bios savour, are these both 2Mb chips? i have tried
>>  writing the RD1 with a image file, but it always fails :( anyone any
>>  pointers?
>> have so far tried to write image aprox 8 times, still with no luck :(
>> this is the output from flashrom :-
> Have you tried to write it and read it back?
> I get the same error
>> Enabling flash write on VT8235...tried to set 0x45 to 0x55 on VT8235 failed (WARNING ONLY)
> ocassionally, but writing works fine. 
>   Stefan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20060809/ce6dceed/attachment.html>

More information about the coreboot mailing list