[LinuxBIOS] RD1-PL on EPIA-M10000 problem

Richard Smith smithbone at gmail.com
Wed Aug 9 15:39:39 CEST 2006

On 8/8/06, lists at actweb.info <lists at actweb.info> wrote:
> hi can someone confirm that i have the following correct?
>  i have an EPIA-M m/board with an SST39SF020A bios chip, along with an RD1-PL 2Mbit bios savour, are these both 2Mb chips?

Looking at the datasheets they are both 2Mbit parts and both are 5V
program.  So they should be equivilent.

 i have tried writing the RD1 with a image file, but it always fails
:( anyone any pointers?

> have so far tried to write image aprox 8 times, still with no luck :(
> Original BIOS
> Enabling flash write on VT8235...tried to set 0x45 to 0x55 on VT8235 failed (WARNING ONLY)

What's up here?  Has the factory bios set some lock so you can't
enable bit 4?  What does that bit do?

> as far as i can tell both are 2M bios, is htere something that prevent writing to the differant chip > number properly?

You IDed both parts correctly which means that writes to flash seem to
be happening.  Can you read the parts ok?
If so then you might try flashing in your LinuxBIOS image and then
read the image back from the part to see if it wrote anything close to
what you expected where you expected.

Richard A. Smith

More information about the coreboot mailing list