[LinuxBIOS] Build broken?

beneo beneo at comcast.net
Thu Nov 10 04:02:23 CET 2005

Thanks for the pointer. I tried it, but still has some issues, hope a guru
can point me a little more.

I changed the ROM_IMAGE_SIZE to 128k from 64K for both normal and fall back,
the PAYLOAD_SIZE changed to 128K too.

But I still get a error message like this:
objcopy --gap-fill 0xff -O binary linuxbios linuxbios.strip
gcc -o buildrom
./buildrom linuxbios.strip linuxbios.rom /export/1/payloads/filo.zelf
0x20000 0x40000
linuxbios image is 131080 bytes; only 131072 allowed
Linuxbios input file larger than allowed size!

This only happens to my fallback image. I traced the code, indeed, My
linuxbios.strip file has a size = 131080, which is too large. But the size
of my linuxbios file was only 124570. the objcopy seems created a too large
linuxbios.strip for me.

More interesting thing is that I have a older tree, (8 month older tree) In
that tree, my linuxbios file size was 122982, the objcopy successfully
created a linuxbios.strip file with a size 65536. It must used some
compression. Since I don't know much about objcopy, I can not tell what it
used. The only difference I can tell is that objcopy was look like this:
objcopy -O binary linuxbios linuxbios.strip. (Note: without "--gap-fill 0xff
" option, but don't know if it would make any difference)

Does anybody know what I did wrong or missed?

By the way, my linuxbios_ram.rom size is 31614, crt0.o size is 87388.
Payload size is 42784.



----- Original Message ----- 
From: "Ronald G Minnich" <rminnich at lanl.gov>
To: "beneo" <beneo at comcast.net>
Cc: <linuxbios at openbios.org>
Sent: Wednesday, November 09, 2005 12:00 PM
Subject: Re: [LinuxBIOS] Build broken?

> beneo wrote:
> > I tried rev 2064, on two targets: tyan/s2891 and amd/serenade, both gave
> > an error like this:
> >
> > ---
> > gcc -m32 -nostdlib -nostartfiles -static -o linuxbios -T ldscript.ld
> > /usr/bin/ld: section .reset [fffdfff0 -> fffdffff] overlaps section .rom
> > [fffd7da8 -> fffe08df]
> > /usr/bin/ld: section .id [fffdffd7 -> fffdffef] overlaps section .rom
> > [fffd7da8 -> fffe08df]
> > collect2: ld returned 1 exit status
> > make[1]: *** [linuxbios] Error 1
> > ---
> This is the 'your flash part is too small or your payload is too big'
> error. I apologize for the lousy error diagnostic, this is on our
> Post-sc2005 list of things to fix.
> ron
> -- 
> LinuxBIOS mailing list
> LinuxBIOS at openbios.org
> http://www.openbios.org/mailman/listinfo/linuxbios

More information about the coreboot mailing list