[LinuxBIOS] still no luck on smartcore-p5

Kjell Svensson lists at endian.se
Fri May 20 18:09:57 CEST 2005

Hi again,
I've left the lab for the week now, so I can't check what DIMM type 
we're using until Monday.
But I do now for sure they work well using the factory BIOS settings, 
we have several hundred units shipped running Linux well on them 
without customer complaints.

I'm not sure I understand what I could use memtest86 for at this point? 
Since I'm not able to start any payloads from LinuxBIOS, I wouldn't be 
able to run memtest from that?
Or do you mean I should run memtest86 started from the route factory 
BIOS -> GRUB -> memtest86? If so, what is it I should look for??

Are there any special linuxbios memory settings you believe I could try 
with more conservative settings?
But if it's a DRAM issue, wouldn't then the LinuxBIOS itself crash 
then? Isn't LinuxBIOS relocating itself into the DRAM during startup?


On 20 maj 2005, at 17:32, Ronald G. Minnich wrote:

> On Fri, 20 May 2005, Kjell Svensson wrote:
>> Well, the LinuxBIOS booted and everything looked OK up until the same 
>> point as I
>> have seen before from my builds; elfboot is started, but the payload 
>> seems
>> completely dead... :-(
> most likely this is a memory programming issue then. We've had lots of
> trouble with the tiny DIMMS used on these cards -- the fuctory bios
> programs them very conservatively, or linuxbios gets something wrong, 
> or
> some combination of the two, and result is what you are seeing.
> Recommend you get memtest86.
> Also, the memory that has worked well for us is Apacer. What I have on 
> my
> SC520 is the Apacer 128MB UBN PC133 CL3 memory.
> ron
> _______________________________________________
> LinuxBIOS mailing list
> LinuxBIOS at openbios.org
> http://www.openbios.org/mailman/listinfo/linuxbios

More information about the coreboot mailing list