Fwd: [LinuxBIOS] still no luck on smartcore-p5

Kjell Svensson kjell at endian.se
Fri May 20 10:44:38 CEST 2005

Hi again,

I just tried the romimage - It didn't work!
Well, the LinuxBIOS booted and everything looked OK up until the same point as I
have seen before from my builds; elfboot is started, but the payload seems
completely dead... :-(
Since I saw the payload in the romimage was etherboot, I also hooked up the
ethernet and started sniffing it with ethereal, but no packets were ever sent on
the ethernet. I have also checked that nothing comes out on the VGA console.
My conclusion is that the Etherboot payload either never is
reached, or crashes at an early stage.

Well, I guess this anyway gives me lots of hints by ruling out all the doubts I
had about my config and build process; now I guess there must be something
different between our Smartcore-P5 based hardwares...

Could I please ask you to check what cardtype/revision you're using?
My HW config looks as follows:
DigitalLogic MSM-P5SEN, V3.9, Rev A. It's also marked 03.04 which I guess is the
manufacturing date(?)
This card has a SmartCore-P5 module clocked at 166MHz. There is only one
Revision label on this module, but it has no revision mark on it...
The MSM-P5SEN variant comes without VGA cirquitry, but I have also tried
LinuxBIOS on the VGA-equipped variant we have around here with the same result.
The onboard Flash is a Winbond 29C020CP (i.e 256kB), but LinuxBIOS boots equally
well also from 128kB and 512kB flashes I've tried in the socket.
The card has one SDRAM slot, which we have equipped with a 128MB large module.

Looking for simple answers; could you possibly be using a different size
(larger) RAM, and could the elfboot for this platform have some code fragments
not checking the detected RAM size so that it relocates the payload out inito
the void?

Cheers. /Kjell 

Quoting Kjell Svensson <lists at endian.se>:

> Begin forwarded message:
> > From: "Ronald G. Minnich" <rminnich at lanl.gov>
> > Date: 19 maj 2005 16:45:16 MET
> > To: Kjell Svensson <lists at endian.se>
> > Subject: Re: [LinuxBIOS] still no luck on smartcore-p5
> >
> >
> >
> > no guarantees, but this might be it.
> >
> > it's a 512KB image. What size rom do you have?
> >
> > ron

More information about the coreboot mailing list