[LinuxBIOS] smartcore-p5 fails to elfboot both FILO and etherboot

Kjell Svensson lists at endian.se
Sat May 14 09:51:21 CEST 2005

I was almost sure the DL support in v2 wouldn't with my card, so I 
didn't try that. :-)
Is there any reason the smartcore:s weren't migrated to v2? Any 
interest in me giving it a shot after getting it to work with v1?

Yep, my intended payload is FILO, but I have also tried Etherboot with 
the same result.
I'm trying to load Linux from an ext2 fs residing on the IDE compact 
flash slot in the card. The Linux system is already working well, the 
BIOS work is an attempt to speed up the boot process.
The flash is 256kB, so there's no chance to squeeze the kernel into it, 
and my understanding from the documentation is that FILO should then be 
the way to go. Right?
Since I wanted to avoid possibly screwing up my original BIOS, I have 
burned the romimage into another flash chip with a standalone flash 
programmer in the lab. We didn't have any 256kB flashes in stock, so 
I've been using 128kB and 512kB flashes instead and adjusted the 
PAYLOAD_SIZE accordingly. The result is the same regardless whether I'm 
using 128kB or 512kB flashes - FILO won't come up, but since I haven't 
actually been able to try the original 256kB size I was thinking maybe 
there's something more to adjust than the PAYLOAD_SIZE to compensate 
for another flash size?
I have enabled extensive debugging (level 9), and read the outputs 
carefully (sorry, can't attach the output today since that's on another 
machine in the lab) but I cnnot find anything suspicious there.

Yes, I'm on a serial console. In fact, my DL board is the variant that 
is even not populated with the VGA chipset (optional). Unless the FILO 
config options are very unclear - No, I have disabled console and 
enabled serial at 115200. I have tried the built FILO image by loading 
it from GRUB, and my FILO image then worked fine at the serial link.

The note in the FILO FAQ about a checksum error in LinuxBIOS causing a 
crash, is that something that sounds familiar?


On 13 maj 2005, at 23:05, Ronald G. Minnich wrote:

> the existing digitallogic support in v2 is not going to work on your 
> card.
> So your payload is FILO? And filo won't come up.
> Are you on serial port console? You didn't try to set filo up for 
> console
> did you? What baud rate?
> ron
> _______________________________________________
> LinuxBIOS mailing list
> LinuxBIOS at openbios.org
> http://www.openbios.org/mailman/listinfo/linuxbios

More information about the coreboot mailing list