[LinuxBIOS] New version of ROM posting app

Jon Smirl jonsmirl at gmail.com
Mon Mar 28 20:11:05 CEST 2005

On Mon, 28 Mar 2005 11:05:08 -0700, Li-Ta Lo <ollie at lanl.gov> wrote:
> > > Which version of x86emu are you using? The larger one from XF86 or the
> > > reduced version from Paulo?
> >
> > The one from linux BIOS cvs:
> > linuxbios/src/devices/emulator/x86emu
> >
> Actually, the code on the LinuxBIOS cvs may be the reduced version by
> Paulo, depending on when you check it out. Paulo's version has some
> bug such that it may fail to init the hardware. I did commited some
> fix to the CVS I got from him. But there are some fixed not commited
> dur to the CVS -> TLA transition.

What I used is in the current CVS repository:
:pserver:anonymous at cvs.sourceforge.net:/cvsroot/freebios

> >
> > Note that the reset program needs to run on a recent kernel. Check
> > /sys/bus/pci/devices/0000:01:00.0/rom and make sure it is there. If
> > not you need a more recent kernel.
> >
> How recent should that be? 2.6.11?

2.6.11 is fine. I think it went in around 2.6.9.

> Did you try to link the emulator with GLIBC than klibc? Do they have the
> same behavior?

I haven't tried the emulator with glibc vs klibc. But I have tried
several other programs against both without problem. Problems with
klibc are usually in the form of not being able to compile against it.
Actual bugs in the code are pretty rare now.

> Ollie

Jon Smirl
jonsmirl at gmail.com

More information about the coreboot mailing list