[LinuxBIOS] Geode GX1 and IRQ tables

joep at frog.nl joep at frog.nl
Sat Dec 3 16:04:21 CET 2005

This week I started to create a linuxbios for an embedded Geode GX1 board
(Kontron ETX-mgx). I was delighted to see that it was able to boot Linux
at the first try!

Off course there remain some issues that need to be solved.
The first thing I ran into is that I can't use the ethernet controller.
When I try to load the ethernet module (dmfe.o) I get this message:

PCI: No IRQ known for interrupt pin A of device 00:02.0. Please try using

This reason is that linux is not able to locate the interrupt table,
because linuxbios failed to copy the table to the area at 0xf0000:

Copying IRQ routing tables to 0xf0000...done.
Verifing copy of IRQ routing tables at 0xf0000...failed
Moving GDT to 0x500...ok
Wrote linuxbios table at: 00000530 - 000006b4  checksum e72d

I saw that this issue was discussed earlier in this list (March 2005,
started by ramesh), but I found no reference as to if and how it was ever

Any answers?


Joep Jansen

More information about the coreboot mailing list