[LinuxBIOS] VIA EPIA-MII + fastboot (2.03)

skb tdf klt29 at freemail.hu
Wed Aug 31 22:28:32 CEST 2005


Although I know, LinuxBIOS != VIA fastboot (and mainly
closed source), I have no idea where can I get answer to my
question (There was no success on Via forum or Google).

Since LinuxBIOS can not be compile for EPIA-MII I tried to
reach my aim with fastboot (2.03). After a few hours, it
seems that system is not so far from ready, but
unfortunately still not finished. On the serial debug line I
got the following info:

User Routine 1:Jun 25 2004,18:02:57
VIA WINCE FastBoot/FreeBoot Loader V2.03 for EPIA-M2 Jun 25
Zero memory:0x06000000...
User Routine 2
Check DOC... fail.
Finding Primary/Master IDE...
Enter FindDevice
Identify IDE Device : Heads:16 SectorsPerTrack:63 MBLK:1
Sanity check
FastBootRom:Boot from IDE device:0x31
h/w reset status byte:50
Boot partition found!
(File System ID = 0xff83)
Found file system used by Linux.(File System ID = 0x83)
User Routine 3
Current cursor is at (0,0)
Move loader function from rom to ram
Packet found_os = 0Set VESA VGA mode(for non-MVP4)...
Call jump_loader ()
Enter loader
ReservedRootDirSectors = 0x205, filesys_id = 0xff83
Heads = 0xfe0a, SectorsPerTrack = 0x1
BytesPerSector = 0x0, SectorsPerFat = 0x0
nkimg_cluster = 0xffffffff, nkimg_length = 0xffffffff
KernelPath = hda1:/boot/vmlinuz-m2 
found_os = 0x2
found_os = 0x2
Enter FindDevice
Identify IDE Device : Heads:16 SectorsPerTrack:63 MBLK:1
Sanity check
h/w reset status byte:50
Try to load Linux(0xff83) at dev 0x31
error code:0x1!
Partition starts at 0x3f
Path = /boot/vmlinuz-m2
Enter LoadKernel()
mount succ
Found filename is vmlinuz-m2
File "/boot/vmlinuz-m2" is Found!
ELF Header check ok!
Enter ParsePHDR()
PHDR 0, type=1, Offset=0x001000, Addr=0x010000,
Size=0x000a5c, MemSize=0x004a60
Checksum 0 = 0x6f860000
Clean memory range 0x10a5c - 0x14a60
PHDR 1, type=1, Offset=0x002000, Addr=0x091000,
Size=0x00002c, MemSize=0x00002c
Checksum 1 = 0x30d0000
Clean memory range 0x9102c - 0x9102c
PHDR 2, type=1, Offset=0x003000, Addr=0x100000,
Size=0x13d529, MemSize=0x13d529
Checksum 2 = 0x5b140000
Clean memory range 0x23d529 - 0x23d529

But after this there is no any activity. Can anybody help?
(Maybe this question is off-topic but I think there are
other people who tried fastboot like me).



[freemail] extra 1GB-os postafiókkal, Önnek már van? http://freemail.hu

More information about the coreboot mailing list