[LinuxBIOS] Where to put datasheets in wiki?

Jeff Carr jcarr at linuxmachines.com
Tue Aug 16 03:10:54 CEST 2005

On 08/15/2005 10:27 AM, Li-Ta Lo wrote:

> I don't think you have M-system on our machine. As I said before, the
> problem you have is that flash_rom can not enable flash write on you
> chipset so it just can't detect any flash chip.

Well, I ran flash_rom on a few random machines. Older, newer, etc.
flash_rom found a standard jedec flash chip on one machine:

probe_jedec: id1 0xbf, id2 0x60
SST49LF004A/B found at physical address: 0xfff80000
Part is SST49LF004A/B

But on all others, only mine did the probe_md2802 do anything that was
not just 0xff or 0x11. So I was just going on the assumption (perhaps
bad assumption) that it was finding *something*. In any case, there is
lots of work to do to increase what flash_rom can detect.

Perhaps there are other tools that should be tried. I start to wonder
that I shouldn't be using some other kernel device drivers instead
(mtd,jffs)? The PC_CHIPS_M810LR port guide does this so perhaps this is
the recommended route going foward?

Thanks for your feedback though,

So this is just junk output? It would be nice if the wiki had "good"
output to compare things with.

probe_md2802: IPL_0x0000: 0x6d
probe_md2802: IPL_0x0001: 0x00
probe_md2802: IPL_0x0002: 0x01
probe_md2802: IPL_0x0003: 0x83
probe_md2802: ChipID: 0xed
probe_md2802: DOCStatus: 0xba
probe_md2802: FloorSelect: 0x00
probe_md2802: CDSNControl: 0xb0
probe_md2802: CDSNDeviceSelect: 0x70
probe_md2802: ECCConfiguration: 0xee
probe_md2802: CDSNSlowIO: 0xed
probe_md2802: ECCSyndrome0: 0xee
probe_md2802: ECCSyndrome1: 0xe6
probe_md2802: ECCSyndrome2: 0xed
probe_md2802: ECCSyndrome3: 0xb0
probe_md2802: ECCSyndrome4: 0xff
probe_md2802: ECCSyndrome5: 0xee
probe_md2802: AliasResolution: 0xf1
probe_md2802: ConfigurationInput: 0xe6
probe_md2802: ReadPipelineInitialization: 0xed
probe_md2802: LastDataRead: 0xc0

More information about the coreboot mailing list