[LinuxBIOS] BIOS Saver RD1

yhlu yinghailu at gmail.com
Wed Aug 3 18:50:49 CEST 2005

You need split mess into two seperate thing
1. does flash_rom support your MB, some mb has gpio to disable the
flash write or last 64KiB
2. are you give dead bios savior.

ps. other thing about flash_rom
1. with 2.6 kernel 64 bit for amd8111 based MB, you can not install 4G
or more in CPU0.
2. with 2.6 kernel 64 bit for Nvidia ck804 based MB, you must install
4G or more in CPU0

solution is use 32 bit 2.6 or 2.4 32bit or 2.4 64 bit.
for case 1 you can command line: maxmem to limit mem to 4G less.

It seems last 4KiB near 4G can not be accessed. when read in Linux it
alreays show 0.

Andi may have some idea about it. maybe something related iommu...


On 8/3/05, Ken Fuchs <kfuchs at winternet.com> wrote:
> > On Wed, Aug 03, 2005 at 11:59:20AM +0900, Jun OKAJIMA wrote:
> > > Probably, most guys here use BIOS Saver.
> > > And it works well?
> > > In mine, RD1 for PLCC gets not being writable suddenly.
> > > I mean, it seems writable but # flash_rom -v fails.
> > > I solved this problem by a quick hack.
> > >
> > > How about yours? You can write RD1 or W49F002U well?
> > > Any problem happen?
> Johnathan McDowell wrote:
> > Even after that it's sometimes a bit flakey and I have to erase, then
> > write it. I've put the board's original BIOS in the RD1 and am writing
> > to the SST 39SF020A instead, which works without problems.
> I've read posts about the RD1 that suggest its integrated flash device
> is low quality and it may take 10 or more flash attempts to get a good
> flash update to the RD1 flash device.
> As a result, many RD1 BIOS Savior users will flash the commercial
> BIOS image (or other known good BIOS image) into the RD1 integrated
> flash device as many times as needed to get an image that boots.
> Then use the original BIOS device to flash test BIOS image (usually
> LinuxBIOS images among this group), since the original BIOS device
> usually flashes OK on the first attempt.
> I've used the RD1 in the above fashion with great success on the
> Tyan S2885 mainboard.
> The same RD1 would not work on the nVidia CK8-04 CRB mainboard.
> I think the CK8-04 CRB requires a flash device that the RD1 does
> not support.  However, the RD1 worked well as an "do nothing" adapter
> which allowed swapping the BIOS flash device between my flash burner
> and the mainboard without any wear to the mainboard's BIOS socket.
> BTW, my flash burner is an older Enhanced Willem Universal Programmer.
> I got mine for only $60 US over a year ago.  I've seen it for less
> than $40 on eBay a few weeks ago.  The newest model is going for about
> $50 US.  It does a LinuxBIOS flash in about 5 minutes; not bad for a
> $60 burner.  However, it does require changing DIP switches to match
> an image for each device it can program.  Great for the amateur or
> professional with a small budget.
> > > BTW, a cable of your RD1 is not broken?
> > > I needed soldering to fix it.
> > Mine was fine out of the box.
> Mine cable and switch worked fine out of the box as well.
> Sincerely,
> Ken Fuchs <kfuchs at winternet.com> ami-mac-sun
> _______________________________________________
> LinuxBIOS mailing list
> LinuxBIOS at openbios.org
> http://www.openbios.org/mailman/listinfo/linuxbios

More information about the coreboot mailing list