Getting Started with freebios2!

backblue backblue at
Tue May 18 20:55:01 CEST 2004

I like to develop, linuxbios to my motherboards, but none of them are suported, i will show you some lspci of them:


00:00.0 Host bridge: Silicon Integrated Systems [SiS] 5597 [SiS5582] (rev 02)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513 (rev 01)
00:01.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:0a.0 Ethernet controller: VIA Technologies, Inc. VT86C100A [Rhine] (rev 06)
00:13.0 VGA compatible controller: Silicon Integrated Systems [SiS] 5597/5598/6326 VGA (rev 65)


00:00.0 Host bridge: Intel Corp. 430VX - 82437VX TVX [Triton VX] (rev 02)
00:07.0 ISA bridge: Intel Corp. 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
00:07.1 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
00:13.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 64)


00:00.0 Host bridge: Intel Corp. 430FX - 82437FX TSC [Triton I] (rev 01)
00:07.0 ISA bridge: Intel Corp. 82371FB PIIX ISA [Triton I] (rev 02)
00:07.1 IDE interface: Intel Corp. 82371FB PIIX IDE [Triton I] (rev 02)
00:0e.0 VGA compatible controller: S3 Inc. 86c764/765 [Trio32/64/64V+]
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:04.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
00:04.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0d.0 SCSI storage controller: Initio Corporation 360P (rev 02)
01:00.0 VGA compatible controller: S3 Inc. Savage 4 (rev 02)

I have some more machines, but i would like to know if any of these ones it's suported?


On Tue, 18 May 2004 08:20:49 -0400
"Jay Miller" <jmiller at> wrote:

> Disclaimer:  I too am a N00B and these are my observations thus far.
> They may not be 100% correct, but these things have worked for me.  I
> hope that they'll help other N00Bz get started.
> Well I stumbled upon freebios2 when I couldn't find support in the
> freebios tree for my Tyan s2885.  Then I noticed under the CVSWeb
> browser for the project the freebios2 directory.
> Apparently, this is what will be LinuxBIOS V2.  They've done away with
> kernel patches, so you don't need to worry about patching the kernel
> like in V1.  Instead there is an intermediary payload that can be
> Etherboot, FILO, or some other loader to get your Linux kernel into
> memory.
> If you're like me, all of a sudden CVS access stopped working.  Well,
> they changed the BIND implementation, so the documentation is out of
> date.  You need to use, "cvs
> -d:pserver:anonymous at login".
> There is still no password for anonymous login.
> Build the documentation under freebios2/documentation.  It will give you
> a solid overview of how the project works, including how to download the
> source you just downloaded. ;-)
> Freebios2 supports a number of newer boards.  Tyan are particularly
> well-supported and the EPIA boards are actively being worked on.  Look
> under, "freebios2/targets..." for the collection.	
> Once you've selected a vendor and mainboard you should execute,
> "./buildtarget <vendor>/<board>".  This will generate all sources
> specific to your mainboard.  To make a rom image, start your make in the
> freebios2/targets/<vendor>/<board>/<board> directory.  If all goes
> smoothly you should get a linuxbios.rom image.
> There are a number of methods and I'm not versed enough to cover them
> all.  But I have successfully used the BIOS flash utility from AMI, and
> I currently use a professional Data I/O burner.  I spent a lot of time
> trying to figure out the proper format to use on my burner.  There is no
> format; it's just a straight binary image, so use binary mode (on the
> Data I/O it's "absolute binary (16)").
> There is also a flash-n-burn utility in the source tree.  Perhaps
> someone on the list can add the specifics of how to get that going on
> this thread.
> First take a look at freebios2/targets/<vendor>/<board>/  This
> is the main configuration file for your ROM image.  This is where you
> specify what payload to use, and most of the settings that anyone would
> care about.  Make sure to do a "./buildtarget <vendor>/<board>" whenever
> you modify this file.
> However, in my case I was running into issues running my dual-processor
> board with only one processor.  As it turns out there is another
> located in freebios2/src/mainboard/<vendor>/<board>.  This
> file controls the contents of some of the generated sources for your
> board.  To date, this is the only way I was able to prevent my ROM image
> from trying to initialize a CPU that wasn't there. 
> In most cases the VGA support just isn't there yet.  So go find yourself
> a null modem cable and hook up your console at 15200-8-N-1, and sit back
> and watch the fireworks!
> I'm currently exploring this area.  The first payload I used
> successfully was FILO.  No you don't make pastry with it.  It is a
> bootloader that acts much like LILO.  You can get the source here:
> If you have an IDE disk with a Linux kernel on it, this is the way to
> get started.
> If you're diskless then you may want to try Etherboot:
>  This payload gives you the ability to
> load over the network, but requires you to configure a DHCP server and
> TFTP server at a minimum.  
> Like LinuxBIOS, Etherboot expects an ELF formatted image, so if you're
> loading a kernel across the network you need to run it through
> mkelfImage.  As of now the correct version to use is 2.5.  You can get
> the latest sources here:
> This is my latest N00B stumbling block, and unfortunately I haven't
> found an answer.  I know that it's a compressed elf format, but I can't
> figure out what I need to do to get elfboot (part of LinuxBIOS) to load
> payloads with the ZELF extension.  So for now I would recommend N00Bz
> stick with ELF format, until we get a definitive answer.
> Hope this is helpful, good luck!
> Jay Miller
> Actuality Systems, Inc.
> jmiller at
> _______________________________________________
> Linuxbios mailing list
> Linuxbios at

More information about the coreboot mailing list