EPIA-M "Magic Potion"?

ron minnich rminnich at lanl.gov
Fri Mar 26 11:29:00 CET 2004

On Fri, 26 Mar 2004, John Laur wrote:

> 1) The machine has 512MB SDRAM, but LinuxBIOS only sets up 128MB. Is
> this a problem with my config file? I know that v1 has some limitations
> with memory on this platform. Was there a time when this worked better
> on epia-m?

It's a v1 limitation, which is why I want to start V2 next week.

> 2) I cannot for the life of me flash the BIOS under Linux. For now, I
> have to reboot to a DOS floppy and flash the original BIOS, then reboot
> again and flash the LinuxBIOS image (AWFLASH will for some reason not
> flash a LinuxBIOS image over a LinuxBIOS image already on the flash
> part) I have run 'setpci -s 0:11.0  40.b=54' as described in the docs
> and on the mailing list, but flash_rom still detects no flash device.

arg. flash_rom should have "just worked". My guess is we need southbridge 
docs for this thing as it is new hardware.

> 3) Despite my sincerest efforts, VGA is doing nothing. I have extracted
> the VGA bios from both /proc/kcore as described in the HOWTO and from a
> ROM image using CBROM (padded to 64k).. neither of these work. The VGA
> bios I'm trying is from the latest release of the BIOS from VIA.

let's do one thing at a time ... let's fix the first two things. Do we 
have chipset docs?

> I understand that some people are having success on epia-m/vga using a
> checkout from last july and a patch from Dave Ashley.. I may have
> mistakenly believed that all that made it into CVS, but if not, what is
> the correct checkout date, and where can I find the patch?

I have incorporated dave's patches, which is why it ought to work ...


More information about the coreboot mailing list