ADLO: linuxbios v1 hangs after jumping to boot code at 0x7c00

Simon Xin Cheng scheng at
Wed Jul 14 19:36:00 CEST 2004


Thanks for your suggestions. I tried them, however, the system still hangs
when jumping to boot code at 0x7c00.

> Examine this file and see if it has the BIOS extension signature of
> 0xaa55 (or 0x55aa depending on what endian you view it as)  You should
> also see some text iding the bios.

I enabled all shadowing and found 0xaa55 and bios copyright information at
the beginning of file.

> In ./util/ADLO/bochs/bios/rombios.c there should be a #define
> DEBUG_SERIAL.  Set that to 1 and all of the bios messages will go out
> the serial port.

My source has DEBUG_SERIAL and by default it is enabled. Nothing appears
for this default configuration.

I also tried to disabled DEBUG_SERIAL, but no video appears either.

Right now I suspect that something wrong with loder.s. My question is how
to debug loader.s? Thanks again.

Simon Cheng

More information about the coreboot mailing list