Filo Error Help

YhLu YhLu at
Mon Jul 12 14:29:10 CEST 2004

I mean if you build tg3filoide_disk.zelf,  it will confuse the Etherboot. So
you can only build tg3filo.zelf or tg3ide_disk.zelf.
Do you have spare IDE disk? If So format the disk into ext3 or fat format
and copy the .elf file into it.
Then connect that to your MB do test.

From: David Aubin [mailto:daubin at] 
Sent: Monday, July 12, 2004 12:50 PM
To: YhLu
Cc: Hendricks David W.; ron minnich; LinuxBIOS
Subject: RE: Filo Error Help

  I am unable to get my kernel & initrd off of the usb stick.  I was reading
through the documents and came across this line in README.etherboot_in_filo:

You can not use filo and ide_disk at the same time.

  Can you tell me what this means?  Do I need to rebuild filo without IDE
support to get USB support?

  Just to recap:  My kernel & initrd fails as the initrd execution
complaining of
a bad CRC when I use the elf as a payload to load with with filo.  I then
uda1:/kernel initrd=/boot/initrd root=/dev/sda1 and I get those td errors.
I then
tried your ramfs.elf and I get the same behavior are my elf image with the
complaining when the initrd portion is executed.  Note, I have confirmed my
works with etherboot, just not filo yet....

  The CRC error makes me think that the image did not get loaded correctly
by the elf boot.  Can you confirm you used Eric's mkelfImage2-5?  Here is
my dump of the readelf -a.  

ELF Header:
  Magic:   7f 45 4c 46 01 01 01 00 00 00 00 00 00 00 00 00
  Class:                             ELF32
  Data:                              2's complement, little endian
  Version:                           1 (current)
  OS/ABI:                            UNIX - System V
  ABI Version:                       0
  Type:                              EXEC (Executable file)
  Machine:                           Intel 80386
  Version:                           0x1
  Entry point address:               0x10000
  Start of program headers:          52 (bytes into file)
  Start of section headers:          0 (bytes into file)
  Flags:                             0x0
  Size of this header:               52 (bytes)
  Size of program headers:           32 (bytes)
  Number of program headers:         5
  Size of section headers:           0 (bytes)
  Number of section headers:         0
  Section header string table index: 0

There are no sections in this file.

Program Headers:
  Type           Offset   VirtAddr   PhysAddr   FileSiz MemSiz  Flg Align
  NOTE           0x0000d4 0x00000000 0x00000000 0x00088 0x00088 RWE 0
  LOAD           0x00015c 0x00010000 0x00010000 0x0559c 0x1aa24 RWE 0
  LOAD           0x0056f8 0x00091000 0x00091000 0x00000 0x00070 RWE 0
  LOAD           0x0056f8 0x00100000 0x00100000 0x1a952a 0x700000 RWE 0
  LOAD           0x1aec22 0x00800000 0x00800000 0x2769f5 0x2769f5 RWE 0

There is no dynamic segment in this file.

There are no relocations in this file.

There are no unwind sections in this file.

No version information found in this file.


On Fri, 2004-07-09 at 15:48, YhLu wrote: 
I have got two cpus and four dimms for every CPU.




From:David Aubin [mailto:daubin at] 
Sent: Friday, July 09, 2004 12:07 PM
To: YhLu
Cc: Hendricks David W.; ron minnich; LinuxBIOS
Subject: RE: Filo Error Help



  Yes, I did, but I don't have a DHCP environment so it kept searching at
the DHCP phase.

  This problem is odd.  I can boot my elf fine with etherboot, but not with
filo.  I can boot
my kernel fine with filo, but not the initrd.  I can even boot your kernel
of the ram.elf you
sent me, but when it hits the initrd it fails with the same error as mine.

  I suspect either my filo is not configured like yours or that there is a
problem loading a
mulitpart elf (kernel & initrd in filo).  I'm confused as to why filo didn't
just use the etherboot
portion of elf_load.  It could be you were on the, "bleeding" edge? ;)  

  Can you tell me how much memory you have in your working system?  I have
one cpu and 512meg memory.  Curious if loading it high & it runs out of
memory or
something like that.


On Fri, 2004-07-09 at 13:05, YhLu wrote: 
Did you try the tg3--filo.zelf I sent to you?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.gif
Type: image/gif
Size: 1066 bytes
Desc: not available
URL: <>

More information about the coreboot mailing list