LinuxBIOS problems with DoC

Michel Belleau michel.belleau at
Wed Aug 27 12:48:01 CEST 2003


DIP2PLCC adapter
DoC Millenium 8MB
Slackware 9.0 on the HD

I downloaded via CVS the latest version of Linuxbios and made my epia.config 
file. I can hotswap my BIOS chip with the DoC and Linux sees it when I load the 
modules. I can erase the chip and write whatever to it.

I can build a romimage (256k) with Linuxbios but I don't have to guts yet to 
flash it on my original chip. *** Can I write it on the DoC? How?

I don't seem to be able to build with the USE_DOC_MIL=1 option set in the 
config file. The make command always result in a failure, because "dd" doesn't 
have a valid argument for the size (it's a negative value). *** What are the 
values needed in the config file to prepare Linuxbios to be flashed on a DoC? I 
tried ROM_SIZE=838xxxx but the resulting "romimage" file is too big for the DoC.

*** What are the steps to write the BIOS onto the DoC? Can I go step by step 
and check out what's wrong easily?

Here's what I tried yesterday (by heart).

modprobe doc2001 && modprobe docecc && modprobe docprobe (my DoC is found)
erase /dev/mtd0 0 1024 (which erases the entire DoC, right?)
dd if=docpil of=/dev/mtd0 (docipl is supposed to be at the first block, right?)
dd if=docipl of=/dev/mtd0 seek=1 (docipl is at the second block too, right?)
dd if=romimage.via-rhine of=/dev/mtd0 seek=2 (i TRIED by guess to put the 
romimage I built earlier right after the two docipl)
(shut off the computer beacuse it hangs at "Rebooting the system...")
When I power it up, nothing comes up on my serial console, just like when I 
tried starting the board without a BIOS chip.

What can I do to test gradually my setup? What did I did wrong? Help me out 
please ;-)

Michel Belleau <michel.belleau at>

More information about the coreboot mailing list