Weird behaviour with new config method

Eric W. Biederman ebiederman at
Mon Aug 4 19:01:01 CEST 2003

Greg Watson <gwatson at> writes:

> At 2:56 PM -0600 4/8/03, ron minnich wrote:
> >On 4 Aug 2003, Eric W. Biederman wrote:
> >
> >>  Previously when we had this conversation we tried for a minimum python
> >>  of 1.5 and the old config tool manages that.  We may need to bump the
> >>  python requirement but we this needs investigation to see why the earlier
> >>  versions of python have problems.
> >>
> >
> >we're going to have to bump minimums anyway. romcc fails for me on RH 7.3.

Hmm.  I will take a look later.  But my default compiler is 2.95.4 and I believe
romcc still compiles with that.  Dropping egcs-2.91.66 is unfortunate but
livable.  With compilers and even more so with binutils pushing the
requirements is not a big deal as it is necessary to support the
newest hardware.

We have no innate requirement for python which makes me worry much
more about pushing the version.

> It'll have to be version 2.0 at a minimum since yapps (and config.g) depends on
> some 2.0 features. It maybe a later version depending on what Eric's problem
> turns out to be.

Hopefully we can track that down.  A few weeks ago it worked with
my version 2.1 of python.


More information about the coreboot mailing list