R: Problems with etherboot + AA patch IDE

Pellanda Luca Luca.Pellanda at italtel.it
Thu Apr 3 03:31:01 CEST 2003

When I run " make bin32/3c900-tpo.ebi"
it's ok but if I try to run "make bin32/3c900-tpo.fd0"
I see the same error.


-----Messaggio originale-----
Da: Adam Agnew [mailto:agnew at cs.umd.edu]
Inviato: giovedì 3 aprile 2003 10.21
A: Pellanda Luca
Cc: 'linuxbios at clustermatic.org'
Oggetto: Re: Problems with etherboot + AA patch IDE

Instead of running "make", run "make bin32/sis900.ebi" or possibly "make
bin32/mynetcard.ebi" if your board doesn't use a sis900 (not that it
should matter, the network booting is left as a fall back if the polled
ide booting doesn't work).

- Adam Agnew

On Thu, 3 Apr 2003, Pellanda Luca wrote:

> I'm running as and compiling etherboot 5.0.6 + the AA IDE
> patch  found on the list causes problems:
> -DBA
> s -ffreestanding -fstrength-reduce -fomit-frame-pointer -mcpu=i386
> -malign-jumps
> =1 -malign-loops=1 -malign-functions=1 -Wall -W -Wno-format -Wno-unused
> N_MAJOR=5 -DVERSION_MINOR=0 -DVERSION=\"5.0.6\" -DRELOC=0x400000
> | as
>   -o bin32/start32.o
> {standard input}: Assembler messages:
> {standard input}:119: Warning: indirect ljmp without `*'
> {standard input}:235: Error: suffix or operands invalid for `ljmp'
> make: *** [bin32/start32.o] Error 1
> I think that RELOC is not good value. Why ?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20030403/df11a531/attachment.html>

More information about the coreboot mailing list