fdisk DoC ?

Antony Stone Antony at Soft-Solutions.co.uk
Fri Sep 13 09:32:01 CEST 2002


Having successfully got LinuxBios to boot from a DoC device, I'm now trying 
to move on to having a root file system in the DoC as well, so I can do away 
with the hard disk altogether...

I'm trying to follow the instructions in the LinuxBios FAQ for "How do I put 
a filesystem on DoC?" and I can't seem to get the DoC partitioned...

if I do:
  ./nftl_format /dev/mtd0 2097152 6291456
as the example shows, then the format appears to go okay, but when I
  modprobe nftl
I get in dmesg:
  NFTL Media Headers at 0x0 and 0x100000 disagree.
  Could not find valid boot record.
  Could not mount NFTL device
and fdisk won't recognise /dev/nftla

Alternatively, though, if I run nftl_format without any offset or size 
  ./nftl_format /dev/mtd0
again it appears to go okay, and when I
  modprobe nftl
I get a successful /dev/nftla which fdisk *can* format.

However, if I do that, how do I get my LinuxBios boot kernel into the DoC as 
well as the root file system ?

I'm using an 8Mbyte DoC MD-2800-D08 and Linux kernel 2.4.19

Anyone know what I'm doing wrong ?



If at first you don't succeed, destroy all the evidence that you tried.

More information about the coreboot mailing list