Trouble getting started.....

Antony Stone Antony at
Sat Sep 7 13:30:00 CEST 2002

On Saturday 07 September 2002 6:03 pm, Antony Stone wrote:

> On Saturday 07 September 2002 5:16 pm, Steve M. Gehlbach wrote:

> > I suspect Antony needs either "kbd-reset" on the kernel command line or
> > "keyboard=1" in the nsuperio line in mainboard/Config.
> Thanks for the suggestions Steve, but no, neither of those (not even both
> together) worked.

Just in case it helps, I spotted the NO_KEYBOARD option in some of the other 
motherboard config files, so I thought "if it's not going to work, I may as 
well disable it, then it won't waste time trying to get it working", so I put

option NO_KEYBOARD=1

into my config file, built a new image and re-flashed it, but I still get 
exactly the same several hundred "pc_keyb: controller jammed (0xFF)" messages 
at startup.

However, I have noticed a discrepancy between the box the motherboard came in 
and the manual which was with it, and although I said previously that it was 
a PC-Chips M810LMR, the manual says it's actually an M810LR - if there's any 
other info I can provide to pin down whether this is significant please let 
me know.

> The biggest thing I'm trying to fix now is the onboard ethernet interface
> (SiS900) which the standard kernel driver tells me (from dmesg):
> sis900.c: v1.08.04 4/25/2002
> PCI: Found IRQ 5 for device 00:01.1
> PCI: Sharing IRQ 5 with 00:01.6
> eth0: No MII transceivers found!
> Under the normal Bios boot, the same driver gives me:
> sis900.c: v1.08.04 4/25/2002
> PCI: Found IRQ 12 for device 00:01.1
> eth0: Realtek RTL8201 PHY transceiver found at address 1.
> eth0: Using transceiver found at address 1 as default
> eth0: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 12, 00:07:95:e2:c0:b6



Perfection in design is achieved not when there is nothing left to add,
but rather when there is nothing left to take away.

 - Antoine de Saint-Exupery

More information about the coreboot mailing list