There is something odd going on with eepro-100

Ronald G Minnich rminnich at
Thu Oct 10 12:04:01 CEST 2002

Here is the scenario. This is a pre-release etherboot from Eric that has
worked well on a number of platforms. The version is 5.1.2rc4.eb5.

I take two identical advantech PCM-5283-2 systems, and put in a linuxbios
flash that has worked fine for many months on a PCM-5823-1. The Etherboot
I have built will boot preferentially from Compact Flash, loading a kernel
and initrd which uses eepro100 to contact a server. If no flash is found,
then it does a boot over Ethernet.

		System A		System B
CF boot Linux	Works			Works

No CF, boot net	Works			Fails; sends DHCP but never sees
					reply. Packet is visible on
					network and dhcpd responds

So, we have an interface which seems to work, and works on linux. It's
basically the same board. etherboot correctly reads the MAC address from
ROM. dhcpd sees packets from etherboot in both cases and responds. But
System B never sees the reply ... this is really very odd.

Here is the best part of all. An older flash, running etherboot 5.0.6,
System B works fine. Yikes!

I have no idea what relationship this has, if any, to the Smartcore
problem I have been having, but it is at least pretty suspicious. The
symptoms are almost identical.

Anyway, I'm going to stick with CF for now but wanted to let the community
know what was up.


More information about the coreboot mailing list