file system error

Munjun Kang malas at
Fri Nov 29 03:03:00 CET 2002

Thanks for your reply.

I tried as your suggest.

dd if=/dev/zero of=/dev/hda bs=1024 count=10000 ~ 100000
Segmentation fault's are occured in random by count.

and then, turn off the UDMA feature by hdparm option.
But, I can see same symptom.

In this time, I tried to attach SCSI & IEEE1394 SBP-2 devices.
case1. Adaptec 2930 SCSI adapter + 8GB Seagate SCSI HDD
case2. IEEE1394 Interface card + external IEEE1394 HDD
both cases show the same problem.

Now, I think it's not a DMA problem.
I'm in the maze. hmmmm......

Is there any clear hint?

----- Original Message ----- 
From: "Ronald G. Minnich" <rminnich at>
To: "Munjun Kang" <malas at>
Cc: <linuxbios at>
Sent: Thursday, November 28, 2002 12:55 AM
Subject: Re: file system error

> can you try a few things: 
> - do a raw dd command to the disk from /dev/zero and see if that works, 
> e.g. dd if=/dev/zero of=/dev/hda
> - turn off UDMA, in fact turn off ALL dma at first
> - try to make it run totally PIO
> This is weird, but it does seem like some kind of DMA problem.
> Also, boot under the normal bios and do an lspci -xxx and then do an lspci 
> -xxx under linuxbios and see if you see any IDE setup differences.
> ron

More information about the coreboot mailing list