DOC & CWlinux SDK

Bob Drzyzgula bob at
Fri Nov 8 11:55:01 CET 2002

I'm just now finally able to get back to a project that I
started a few months ago, and I have a couple of questions.
First, though, I want to offer great thanks to Andrew and
CWlinux for their SDK. That stuff really is a tremendous

First, DOC problems. I've spent about a day and a half
getting an M810LMR up and running off a DOC, using one
of CWlinux's images. Part of my problem turned out to
be some flaky DOCs. Of four units I took out of a tube,
two of them have turned out to have faulty sectors, from
what I can tell. After futzing around, I finally came
to the realization that I could not even get eraseall to
work -- it would repeatedly give an MTD erase failure [1]
error. It would fail at the same address every time, but
that address was different for the two DOCs. The other two
DOCs had no such problem. I guess that my main questions
here are (a) are these DOCs toast, and (b) is this common
with DOCs? These are labeled "MD-2800-D08/JAPAN0028HAK 1".

The other issue I had was with regard to the CWlinux
DOC images; I don't think this is a question so much as
an FYI for Andrew and maybe other newbies, I was able to
work around things and I'll be moving beyond his examples
soon anyway.

In, the size of the minix filesystem
appears to be larger than the size of the nftl partition
on the DOC [2].  This is confirmed with a error when I run
the dd to write the filesystem to flash. The filesystem in
the image is small enough to fit,
however [3]. Finally, when I use the docipl, linux.bin.gz.block,
and linuxbios.block from, the
linux commandline gives me consoles on /dev/ttyS0 and /dev/tty0.
The one on ttyS0 works fine, but the one on tty0 has
carriage return issues; the virtual console on tty1 also
works OK. If I use the docipl, linux.bin.gz.block,
and linuxbios.block from but the
minix filesystem from, the
command line gives me a console only on /dev/tty5 and
there's a GUI splash screen. In this case, the virtual
consoles, including the one on tty0, work just fine. 
This has worked out to be the best combination.


[1] (with defective DOC in socket)

[root at linuxbios]# lsmod
Module                  Size  Used by    Tainted: P
binfmt_misc             6980   1
autofs                 11396   0  (autoclean) (unused)
sis900                 15012   1
ipchains               37992  10
ide-cd                 30368   0  (autoclean)
cdrom                  31168   0  (autoclean) [ide-cd]
ext3                   66464   4  (autoclean)
jbd                    52672   4  (autoclean) [ext3]
md                     62976   0  (unused)
usb-ohci               22016   0  (unused)
usbcore                69056   1  [usb-ohci]
[root at linuxbios]# flash_on
[root at linuxbios]# modprobe doc2000
[root at linuxbios]# modprobe docprobe
[root at linuxbios]# eraseall /dev/mtd0
Erasing 8 Kibyte @ 2c000 --  2 % complete.
eraseall: /dev/mtd0: MTD Erase failure: Input/output error
Erased 8192 Kibyte @ 0 -- 100% complete.
[root at linuxbios]# dmesg | tail -2
Ignoring DiskOnChip 2000 at 0xFFFEE000 - already configured
Error erasing at 0x2c000

[2] (with good DOC in socket)

[root at linuxbios]# sfdisk -l -uS /dev/nftla

Disk /dev/nftla: 1019 cylinders, 14 heads, 1 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End  #sectors  Id  System
/dev/nftla1             1     14265     14265  83  Linux
/dev/nftla2             0         -         0   0  Empty
/dev/nftla3             0         -         0   0  Empty
/dev/nftla4             0         -         0   0  Empty
[root at linuxbios]# expr 14265 \* 512
[root at linuxbios]# ls -l data/*minix
-rw-r--r--    1 root     root      7307264 May  3 13:21 data/rootfs.minix
[root at linuxbios]# cat config/*
# partition table of /dev/nftla
unit: sectors

/dev/nftla1 : start=        1, size=   14265, Id=83
/dev/nftla2 : start=        0, size=       0, Id= 0
/dev/nftla3 : start=        0, size=       0, Id= 0
/dev/nftla4 : start=        0, size=       0, Id= 0


[root at linuxbios]# ls -l ../*minix
-rw-r--r--    1 root     root      7303168 Sep  6 07:53 ../

More information about the coreboot mailing list