[coreboot-gerrit] Change in coreboot[master]: soc/intel/denverton_ns: Rename HARCUVAR macros to DENVERTON

Julien Viard de Galbert (Code Review) gerrit at coreboot.org
Wed Jan 24 14:51:09 CET 2018


Julien Viard de Galbert has uploaded this change for review. ( https://review.coreboot.org/23404


Change subject: soc/intel/denverton_ns: Rename HARCUVAR macros to DENVERTON
......................................................................

soc/intel/denverton_ns: Rename HARCUVAR macros to DENVERTON

Harcuvar is the board name, Denverton is the SoC.
Macros is files under soc/ should be named after the SoC not the board.

Change-Id: I1c7d5b93fba386b8e9bd86cf599508e642e21a75
Signed-off-by: Julien Viard de Galbert <jviarddegalbert at online.net>
---
M src/soc/intel/denverton_ns/bootblock/uart.c
M src/soc/intel/denverton_ns/include/soc/fiamux.h
M src/soc/intel/denverton_ns/include/soc/uart.h
3 files changed, 6 insertions(+), 6 deletions(-)



  git pull ssh://review.coreboot.org:29418/coreboot refs/changes/04/23404/1

diff --git a/src/soc/intel/denverton_ns/bootblock/uart.c b/src/soc/intel/denverton_ns/bootblock/uart.c
index bad16de..a81b389 100644
--- a/src/soc/intel/denverton_ns/bootblock/uart.c
+++ b/src/soc/intel/denverton_ns/bootblock/uart.c
@@ -186,12 +186,12 @@
 	register int i;
 
 	/* Check: do we have enought elements to init. ? */
-	BUILD_BUG_ON(HARCUVAR_UARTS_TO_INI > ELEM_OF_UART_TAB);
+	BUILD_BUG_ON(DENVERTON_UARTS_TO_INI > ELEM_OF_UART_TAB);
 
 	/* HSUART(B0:D26:0-1) GPIO init. */
 	early_config_gpio();
 
-	for (i = HARCUVAR_UARTS_TO_INI - 1; i >= 0; --i) {
+	for (i = DENVERTON_UARTS_TO_INI - 1; i >= 0; --i) {
 		pci_early_hsuart_device_probe(0, CONFIG_HSUART_DEV, i,
 					      legacy_uart_ioadr_tab[i]);
 	}
diff --git a/src/soc/intel/denverton_ns/include/soc/fiamux.h b/src/soc/intel/denverton_ns/include/soc/fiamux.h
index 3fd9321..5f65f53 100644
--- a/src/soc/intel/denverton_ns/include/soc/fiamux.h
+++ b/src/soc/intel/denverton_ns/include/soc/fiamux.h
@@ -14,8 +14,8 @@
  * GNU General Public License for more details.
  */
 
-#ifndef _MAINBOARD_HARCUVAR_FIAMUX_H
-#define _MAINBOARD_HARCUVAR_FIAMUX_H
+#ifndef _DENVERTON_NS_FIAMUX_H
+#define _DENVERTON_NS_FIAMUX_H
 
 #include <fsp/util.h>
 
@@ -27,4 +27,4 @@
 
 size_t mainboard_get_hsio_config(BL_HSIO_INFORMATION **p_hsio_config);
 
-#endif // _MAINBOARD_HARCUVAR_FIAMUX_H
+#endif // _DENVERTON_NS_FIAMUX_H
diff --git a/src/soc/intel/denverton_ns/include/soc/uart.h b/src/soc/intel/denverton_ns/include/soc/uart.h
index 29e9024..662d3e9 100644
--- a/src/soc/intel/denverton_ns/include/soc/uart.h
+++ b/src/soc/intel/denverton_ns/include/soc/uart.h
@@ -18,7 +18,7 @@
 #define _DENVERTON_NS_UART_H
 
 #define SIZE_OF_HSUART_RES 0x100
-#define HARCUVAR_UARTS_TO_INI 3
+#define DENVERTON_UARTS_TO_INI 3
 #define PSR_OFFSET 0x30
 #define PCI_FUNC_RDCFG_HIDE 0x74
 

-- 
To view, visit https://review.coreboot.org/23404
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings

Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I1c7d5b93fba386b8e9bd86cf599508e642e21a75
Gerrit-Change-Number: 23404
Gerrit-PatchSet: 1
Gerrit-Owner: Julien Viard de Galbert <jviarddegalbert at online.net>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.coreboot.org/pipermail/coreboot-gerrit/attachments/20180124/7be3ffc3/attachment-0001.html>


More information about the coreboot-gerrit mailing list