[coreboot-gerrit] Change in coreboot[master]: soc/intel/common/block: Add Intel common FAST_SPI code

Barnali Sarkar (Code Review) gerrit at coreboot.org
Fri Apr 21 11:04:31 CEST 2017


Barnali Sarkar has posted comments on this change. ( https://review.coreboot.org/18557 )

Change subject: soc/intel/common/block: Add Intel common FAST_SPI code
......................................................................


Patch Set 25:

(1 comment)

https://review.coreboot.org/#/c/18557/25/src/soc/intel/common/block/fast_spi/fast_spi.c
File src/soc/intel/common/block/fast_spi/fast_spi.c:

Line 360: 
> Yeah, I am planning to push a CL to add flash_probe to the spi_ctrlr struct
Yes, I can do change the name of this function to fast_spi_flash_programmer_probe() and keep it in this file (block/fast_spi/fast_spi_flash.c), provided that, its get called from the original function spi_flash_programmer_probe() as you mentioned above from SOMEWHERE.

But, from where? Where do I keep this function now?
struct spi_flash *spi_flash_programmer_probe(struct spi_slave *dev, int force)
{
   return fast_spi_flash_programmer_probe(...);
}

since, we have already removed the soc/flash_controller.c OR soc/flash_ctrlr.c files entirely.

The spi_flash_probe() function of the spi_flash driver (src/driver/spi/spi_flash.c) will call the .probe of struct spi_ctrlr, which will point to spi_flash_programmer_probe().


-- 
To view, visit https://review.coreboot.org/18557
To unsubscribe, visit https://review.coreboot.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I046e3b30c8efb172851dd17f49565c9ec4cb38cb
Gerrit-PatchSet: 25
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Barnali Sarkar <barnali.sarkar at intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra at intel.com>
Gerrit-Reviewer: Aaron Durbin <adurbin at chromium.org>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan at intel.com>
Gerrit-Reviewer: Barnali Sarkar <barnali.sarkar at intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan at google.com>
Gerrit-Reviewer: Hannah Williams <hannah.williams at intel.com>
Gerrit-Reviewer: Paul Menzel <paulepanter at users.sourceforge.net>
Gerrit-Reviewer: Pratikkumar Prajapati <pratikkumar.v.prajapati at intel.corp-partner.google.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik at intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik at intel.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins)
Gerrit-HasComments: Yes



More information about the coreboot-gerrit mailing list