[coreboot-gerrit] Change in coreboot[master]: soc/intel/common/block: Add Intel common PCR support

Subrata Banik (Code Review) gerrit at coreboot.org
Thu Apr 6 09:41:55 CEST 2017


Subrata Banik has posted comments on this change. ( https://review.coreboot.org/18669 )

Change subject: soc/intel/common/block: Add Intel common PCR support
......................................................................


Patch Set 12:

(3 comments)

https://review.coreboot.org/#/c/18669/12/src/soc/intel/common/block/pcr/pcr.c
File src/soc/intel/common/block/pcr/pcr.c:

Line 28: 	reg_addr += ((uintptr_t)offset & PCR_REG_MASK);
> I see that in APL EDS. but I see no mention of any of that in skylake or ka
Added 2 kconfig for IOSF spec 1.0 and 1.1.

      if (IS_ENABLED(CONFIG_IOSF_1_0))
                reg_addr += ALIGN_DOWN(offset, sizeof(uint32_t));
        else if (IS_ENABLED(CONFIG_IOSF_1_1))
                reg_addr += (uintptr_t)offset;
Just adding 1.0 may not be help to understand what other other we have any how its different hence added both.

Do you care for else condition alone? some assert or die need to introduce if no soc select any of IOSF spec revision?


https://review.coreboot.org/#/c/18669/13/src/soc/intel/common/block/pcr/pcr.c
File src/soc/intel/common/block/pcr/pcr.c:

PS13, Line 119: pcr_and_then_or_
> These should just be named pcr_rmwX for read-modify-write. We already have 
Done


PS13, Line 130: pcr_or_32
> These functions are named inconsistently with the read and write:
Done


-- 
To view, visit https://review.coreboot.org/18669
To unsubscribe, visit https://review.coreboot.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I78526a86b6d10f226570c08050327557e0bb2c78
Gerrit-PatchSet: 12
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Owner: Subrata Banik <subrata.banik at intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra at intel.com>
Gerrit-Reviewer: Aaron Durbin <adurbin at chromium.org>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan at intel.com>
Gerrit-Reviewer: Barnali Sarkar <barnali.sarkar at intel.com>
Gerrit-Reviewer: Bora Guvendik <bora.guvendik at intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan at google.com>
Gerrit-Reviewer: Hannah Williams <hannah.williams at intel.com>
Gerrit-Reviewer: Paul Menzel <paulepanter at users.sourceforge.net>
Gerrit-Reviewer: Shaunak Saha <shaunak.saha at intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik at intel.com>
Gerrit-Reviewer: build bot (Jenkins)
Gerrit-Reviewer: dhaval v sharma <dhaval.v.sharma at intel.com>
Gerrit-HasComments: Yes



More information about the coreboot-gerrit mailing list